Netrunner Home

Corsair Media Keys[solved]


#1

Basically I can’t get the media keys on my Corsair K70 RGB MK.2 to work with Spotify (installed with snap) or a few other audio programs. Any suggestions? I went into Global Keyboard Shortcuts and made sure they were mapped properly, which they are, yet with Spotify in-focus or not the keys won’t interact with it. I also tried it with Yarock, and nothing there either. But when I tried with VLC? They work! I’m so confused…


#2

Make sure first to have Media Playback plugin enabled in the system tray settings.

I assume those media keys control the multimedia mpris player plugin available in plasma. So if the player is appearing in the mpris player plugin then it should work.
So Yarock needs to have an mpris plugin enabled (if there is such a thing even).

As for Spotify running as Snap it might not be able to connect to the mpris interface of the host system as it is running in a sandbox.


#3

How do I go about enabling the Media Playback plugin? I searched around but couldn’t find anything like that. And Yarock does have the option “Enable Mpris” and it’s selected by default. I think it came pre-installed? But the media keys don’t work (I’m assuming I need the plugin you mentioned enabled). Also which version of Spotify should I run? Because it turns out I actually had the Debian version listed on their site. Just out of curiosity I tried the Snap version and sadly, no luck, BUT I noticed it does load my library a lot faster than the Debian one.

EDIT: Well crap… Found it! Media keys work great now haha. Thanks for the reply! Right clicked on the little up arrow in the tray and saw “Configure System Tray…”. Also works just fine with the snap version, luckily.


#4

Nice that you found the solution :slight_smile: