Could not download all repository indexes


When ever I reload the cache in Synaptic I get the above error. I have attached screen shot. And if I try an add also the RESTRICTED it comes up with the error.

What is the problem.



Change those PPA lines like this:


Is it somthing that I have done or will there be an update to fix this sort of thing
I think I have done somthing I am getting way more errors now.

Is there a code I can put in that will re-set it back to when you first install the disto ???

This is nothing new: However, I’m not sure why this happens for some and not for others. You’ll need to fix it yourself for now.

I’m only a moderator here in the forums, and my expertise is in the rolling (Manjaro/Arch) edition. I’m not quite sure if the Netrunner team might fix this issue, when, or even if they know why this happens.

will it be possible for you to pass this onto them please.

I’ll see what I can do.
For now download my attachment and replace your /etc/apt/sources.list with it, make sure to rename it.

Thank you so much. I did a long way around. I made up a virtual machine with netrunner. And then replaced the APT directory on my main machine with the one from the virtual and seem to have solved it. Well it is back to where it is at the start. So will add in the PPA that I do need my self and will see what happens

As long as you got it going again. :slight_smile:

My guess is this error appears when trying to edit the sources file with a graphical tool (which tries to be intelligent but fails) other then the mintsources (Software Sources) tool we ship.
Avoiding third party sources.list editors helps here.

Not sure about that, as I have suffered similar problems without even knowing that source lists and repositories exist! So I haven’t been tinkering.

Wouldn’t it be better to untick the netrunneros packages and the launchpad netrunner lines in the /etc/apt/sources.list.d/official-package-repositories.list and then update and dist-upgrade?

I found that I couldn’t upgrade to Firefox 31, so I did that to get Firefox upgraded. Actually, I wouldn’t have even thought of upgrading Firefox, if the Netrunner fixed Firefox 30 stopped remembering my last opened web pages. I looked into the Netrunner launchpad pages, and saw that nothing much is happening there, so my action was not unwarranted.

I am not going to be that worried about Ubuntu repos breaking things, so I would relocate the Ubuntu Trusty lines in that file to /etc/apt/sources.list and keep the sources.list.d folder for adding ppas. I am not that concerned about Mint-worries, so the normal dist-upgrade would do for me.

What say you, Leszek?

You can do what you want when you know what you do.
As for the majority I would keep the netrunner repos active.

As for the firefox issue you describe. This is clearly a preloading issue and has nothing todo with the version number of firefox.

I’m sure you are right, Leszek. I tried many times to re install Firefox, but it always had the same problem, as it downloaded it from Netrunner repos, actually from the ppa. (I purged it before reinstalling.) So, I blocked the netrunner repos, and downloaded Firefox 31, but that too had the same problem, so I purged it again, and downloaded Aurora using the Ubuntu-Mozilla-daily from Launchpad. It too had the same problem, so I reseted it, and started with a clean slate. Now Firefox (Aurora) works normally.

Maybe, I should’ve reseted Firefox 30 in the first place. Thanks again,
Best regards!