Date&Time password

We also need to fix access do date/time etc (tasks that may need too high privileges)

I’m not sure what the problem with date time access is?

There are two problems about setting date/time:
1-you just can’t set date/time at painel because permission is denied (this is a KDE bug since KDE 4x)
2-kcm module for date/time asks for root password too

Date/time is set is via systemd’s timedated [1]

timedated uses policykit (not kdesudo / kdesu) for privilege escalation to set the system’s date and time.
This does ask for a password confirmation via a popup, but should be working as intended.
Or does it give you a login dialog like the one you were getting with the printer KCM that does not accept your user password?


It could be you need to enter the user password and then when the popup reappears enter it again to be accepted… also you need to untick “set date and time automatically” to be able to alter it manually.

Strange… :huh: Now it worked alright for both panel and kcm, just asking by the administrative-user password.
Problem solved it seems :cool:

Then please edit the title post with [solved]