back to Netrunner | back to Blue Systems

Dependency problems

After an uneventful installation of the OS I went into Synaptic to install the apps I need. Some installed OK, but some appear to have dependency problems. The most serious is Kmail/Kontact, after which I stopped trying, as it is a deal breaker if it is not installable.

[code]“Could not apply changes!

Fix broken packages first.”

“Fix broken packages”:

An error occurred – the following details are provided
E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies[/code]

If I deselect the package “Fix broken packages” does nothing.

I tried Muon, which did install, but:

[code]Unable to mark package – Muon Package manager

The “Kontact “ package could not be marked for installation or upgrade:
Depends: kontact, but it is not installable
Depends: kontact, but it is not installable
Recommends: kontact, but it is not installable
Recommends: kontact, but it is not installable
Recommends: kontact, but it is not installable
Recommends: kontact, but it is not installable
Recommends: kontact, but it is not installable
Recommends: kontact, but it is not installable[/code]

Am I missing any repositories? There are a lot of “jessie-backports main” entries in the repo list unselected.

It is not installable for me either.

You could try and install it from the shell, using the “jessie backport flag”:

sudo apt-get -t jessie-backports install kmail

Tried that, didn’t work, same output as without the -t jessie-backports:

[code]andy@andy-16_09:~$ sudo apt-get -t jessie-backports install kontact

[sudo] password for andy:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kontact : Depends: libkf5kdepimdbusinterfaces5 but it is not going to be installed
Depends: libkf5libkdepim5 but it is not going to be installed
Recommends: accountwizard but it is not going to be installed
Recommends: akregator but it is not going to be installed
Recommends: kaddressbook but it is not going to be installed
Recommends: kmail but it is not going to be installed
Recommends: knotes but it is not going to be installed
Recommends: korganizer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.[/code]

I can find no definitive way to approach this, dpkg --get-selections | grep hold gives no output so I assume there are no actual held packages, broken or otherwise. Someone suggested apt-get autoremove, but when this happened on a fresh install before running any packages it looks doubtful, possibly risky.

I think that this should be officially reported to the maintainers of Netrunner so that a work-around can be found.

In the meantime, however, does adding the rest of the backport repos fix anything?

Unfortunately, those applications from the jessie backports repository depend on an older version of KF5 than what Netrunner supplies.

We are aware of some dependency issues and are working on a unified solution with the upcoming 17.01 release. Basically we will use an advancing snapshot repo from stretch and test all netrunner repos against that, then provide an upgrade path to this consistent base for any 16.09 user. After that, Netrunner users (like Maui users) can opt-in to get the latest packages rolling-style or to stay at any given snapshot in the future. We are confident to get this ready this month.

Thanks, I’ll keep using 14 for a bit longer. 16.09 is looking good so far, I’ll see how it goes once this problem is sorted.

My fail list so far:
Kontact – dependency errors

grub-choose-default – dependency errors
Calibre – dependency errors
Ksnapshot – dependency errors
libreoffice-systray: “unresolvable dependencies”
Depends: libreoffice-core (=1:5.2.3-2~bpo8+1) but 1:4.3.3-2+deb8u5 is to be installed
Depends: uno-libs3 (>=4.4.0~alpha) but 4.3.3-2+deb8u5 is to be installed

  • Edit - just discovered I don’t need that – there is one in Libre Office options > memory.

OK, I see the issue there, ksnapshot has been replaced by Spectacle, this is causing the dependency error for that one.
You also seem the system is trying to mix Llibre Office 5.2.3 on a system that wants to use 4.3.3 available from the main repositories, etc.
If this IS a repository issue as I suspect, you may need to specify every component needed that conflicts with the ones from main repositories, if available in backports.

Add paprefs to the “broken packages” list - trying to get sound in Skype.

Thanks, we will check all those deps for 17.01 to work.

kmail is still not installable in Netrunner 17.03.

Same issue for me in 17.03.

[code]sudo apt-get install kmail -o “Debug::pkgProblemResolver=1”
[sudo] password for xxxx:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) kdepim-runtime:amd64 < none -> 4:16.04.2-2+b2 @rc uN Ib >
Broken kdepim-runtime:amd64 Depends on kdepimlibs-data:amd64 < none | 4:16.04.2-2 @rc uH > (>= 4:15.12~)
Considering kdepimlibs-data:amd64 -2 as a solution to kdepim-runtime:amd64 1
Holding Back kdepim-runtime:amd64 rather than change kdepimlibs-data:amd64
Investigating (1) kmail:amd64 < none -> 4:16.12.2-0neon+9+build5 @un puN Ib >
Broken kmail:amd64 Depends on kdepim-runtime:amd64 < none | 4:16.04.2-2+b2 @rc uH >
Considering kdepim-runtime:amd64 1 as a solution to kmail:amd64 9999
Re-Instated kdepimlibs-data:amd64
Re-Instated kdepim-runtime:amd64
Investigating (1) akonadi-contacts-data:amd64 < 4:16.12.2-0neon+9+build5 @ii mK Ib >
Broken akonadi-contacts-data:amd64 Breaks on kdepimlibs-data:amd64 < none -> 4:16.04.2-2 @rc uN >
Considering kdepimlibs-data:amd64 -2 as a solution to akonadi-contacts-data:amd64 15
Added kdepimlibs-data:amd64 to the remove list
Broken akonadi-contacts-data:amd64 Breaks on kdepimlibs-data:i386 < none @un H >
Considering kdepimlibs-data:amd64 -2 as a solution to akonadi-contacts-data:amd64 15
Added kdepimlibs-data:amd64 to the remove list
Fixing akonadi-contacts-data:amd64 via keep of kdepimlibs-data:amd64
Fixing akonadi-contacts-data:amd64 via keep of kdepimlibs-data:amd64
Investigating (1) kdepim-runtime:amd64 < none -> 4:16.04.2-2+b2 @rc uN Ib >
Broken kdepim-runtime:amd64 Depends on kdepimlibs-data:amd64 < none | 4:16.04.2-2 @rc uH > (>= 4:15.12~)
Considering kdepimlibs-data:amd64 -2 as a solution to kdepim-runtime:amd64 1
Holding Back kdepim-runtime:amd64 rather than change kdepimlibs-data:amd64
Investigating (2) kmail:amd64 < none -> 4:16.12.2-0neon+9+build5 @un puN Ib >
Broken kmail:amd64 Depends on kdepim-runtime:amd64 < none | 4:16.04.2-2+b2 @rc uH >
Considering kdepim-runtime:amd64 1 as a solution to kmail:amd64 9999
Considering kdepim-runtime:amd64 1 as a solution to kmail:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kmail : Depends: kdepim-runtime but it is not going to be installed
E: Unable to correct problems, you have held broken packages.[/code]

There’s a mix of kde package versions of 16.04, 16.08 & 16.12 in the Netrunner Desktop 17.03 release.

The netrunner-1703/kde-applications repo has many kde 16.12 packages (but not all), and debian testing repo has a mix of 16.04 & 16.08 for the remaining packages not found in netrunner-1703/kde-applications.

Will the missing kde 16.12 packages be added to the netrunner-1703/kde-applications repo?
Or, maybe update with the newly released KDE Applications 17.04.

I’m attempting to fix this problem in netrunner-backports. Once I’ve fixed it, I’ll deploy a update. I’ll see if I can also fix this for the 17.03 release.

Quick update, I have fixed kdepim-runtime in the backports repo. I’ll deploy the update in the upcoming days so you can install kmail.

I’ll see what I can do about some of the apps that are still on 16.08 and 16.04, entirely possible that some of them haven’t been released/updated, but I’ll need to go through each one of them by hand.

Thank you very much for your effort. Good luck with the rest of the apps…

Hi
I’ve deployed the backports update for Netrunner 17.03 users. kmail should now work.

Note that you need to enable Akonadi via the “Plasma Services” KCM before it’ll work.

Excellent!!! kmail can be installed without issue.

Please mark the thread as solved :slight_smile: