Netrunner Home

Distro Update


Hi everybody,

Wow, looks like I somehow got first post. I just got a Pinebook and have been experimenting with Netrunner on it. I’ve used dd to copy the image to the internal emmc, and it boot fine.

The people over at the Pinebook forums are talking about NetworkManager not auto-connecting to wifi on boot, which I know is a regression in Plasma 5 from months ago and is currently fixed. For this reason, I’m attempting to update the distro to a later version of Plasma 5…

My first experiment failed. I tried enabling the Debian, Netrunner, and Netrunner-rolling repositories in /etc/apt/sources.list.d and then doing an apt-get dist-upgrade. Everything updated well, and then upon reboot, X wouldn’t load due to a difference in ABI version between the device driver and X.

I suppose there are two solutions to this problem:

  1. Find a newer device driver (I have no idea what it is or how to find it; I’m assuming it’s something not managed by the package manager or in a repository?).

  2. Configure apt not to update X and try the update again.

I’m going to try #2 unless somebody has any more information. My goal is through upstream, fix the NetworkManager issue (it was a Plasma 5 regression that has now been fixed), and possibly the sleep issue.

Can anybody offer me any advice? Thanks!


(Some info cross-posted from the Pine64 forums)

Success! I just booted the machine after updating, and I’m posting this from my Pinebook! I can report that auto-connecting to wifi is fixed. I haven’t yet tested sound/sleep, but will do that next (I want to do a cold shutdown/restart first). Here’s what I did to get it updated from the Debian repositories:

  1. In /etc/apt/sources.list.d are three files: debian-testing.list, netrunner.list, and netrunner-rolling.list. In each of them are various repository URLs, commented out. Re-enable them by removing the hash mark (#) from the beginning of the line.

  2. Run sudo apt-get update. Then run apt-get dist-upgrade, but DON’T hit Y to upgrade; hit N. Take note of the X packages that are listed for upgrade (I copy/pasted them into a text file). For convenience, here’s the list:


[/list]3. For each of the packages above, run

apt-mark hold [package name]

This tells the package manager not to upgrade these packages, thus avoiding the ABI mismatch error I ran into at first.

  1. Run apt-get dist-upgrade. This will take a while and download a lot of stuff, including an updated Plasma 5 desktop with the fix for the wifi issue. You’ll also be asked some questions; where possible, just keep all the current settings.

  2. Reboot, and you’ll connect to wifi automatically.

After this, I tested sleep, which didn’t work. After applying the workaround sleep script here, I got sleep working, except that as reported, sound doesn’t return after sleep.

So far, so good! I’ve installed Netrunner as the main OS to my Pinebook’s eMMC. I plan to continue to “roll” with it and see how things go.