Dolphin panels/places problem

I’m using Netrunner 14.2 on a couple of laptops, and have the same problem on both of them.
The “places” panel in Dolphin has repeated the listed items (i.e.‘home’‘network’‘trash’‘root’ etc.) many times. I have tried to find a fix in ‘Settings>Configure Dolpine’ but no luck. It is possible to delete items one at a time, but the process of reiteration continues.
I have Mint 17.2 KDE on another laptop which does not have this problem… i.e. only one iteration of the items, and a list of mounted devices at the bottom.
I have disabled the places panel, so I can live with this minor irritation; but I would prefer to have it visible if I could get it to behave normally.
Any ideas?

What version of kdelibs is installed in Netrunner 14.2?

Add your own place/folder and the others will stop repeating.
Then delete all the duplicates.

9th November 2015, 20:45 (This post was last modified: 10th November 2015, 8:47 by smoreau.)

I have perhaps found a workaround of the bug.
I observed that my desktop, which did not exhibit the bug, has already a favorite within the panel;
I chose to erase this favorite (right click on it). then dolphin started to duplicate home, root, network, trash.
Each session of dolphin added a new series.
Then I decided to add a new favorite on the panel, and i deleted the previous duplicate (right click option).
As expected now the duplicate of entries did not occur.

I suspected that machines which did not exhibit that bug have already favorites on the panel or at least the file indexer (baloo) activated.

Sorry. but Askimet won’t allow me to reply… seems I get labelled as spam.

Since “new reply” seems to work, I’ll try that.
I don’t know how to add a new favorite to the places panel. Right-click popup gives option of ‘add new entry’, so I tried Downloads in Home. Also tried the ‘show in application dolphin only’ option both checked and unchecked.
Still cannot do more that one thing (e.g. ‘remove entry’) before dolphin freezes and popup ‘terminate appilication dolphin’ appears.
To delete the hundred plus entries will take a long time this way. Also I don’t think the new entry (Downloads) is what is being suggested here.

First make sure baloo (desktop search) is disabled.
Also, If you have any left over nepomuk files, delete them.

Next, open a terminal and type the following:

rm  ~/.local/share/user-places.xbel
rm  ~/.local/share/user-places.xbel.back
rm ~/.local/share/user-places.xbel.tbcache
rm ~/.kde4/share/config/user-places.xbel
rm ~/.kde4/share/config/user-places.xbel.back
rm ~/.kde4/share/config/user-places.xbel.tbcache

Note: Akonadi can also have an effect on this. If this doesn’t fix the issue you may be experiencing this bug:

Make a folder and left click hold and drag across.

Thanks stennie, at least I managed to get a ‘Favourite’ entry. But I think I’m going to just live with keeping the panel closed. There are hundreds of entries and it is frustrating to have to delete one, click a bunch on close dolphin, restart it and do one more.
As to the other suggestions… I have never used baloo, nepomuk or Akonadi, so it seems like more effort than it’s worth to get this thing fixed.

Did you try deleting the files I mentioned in my post?
Also, this is a known bug when using an older kdelibs than ver. 4.14.8:

Note: Next time you have an issue, question or advise related to Netrunner 14, could you please post in the Netrunner 14.x LTS (KDE4) section of the forums? This not only helps us speed up our testing or research on the issue, but it also makes it easier for other users to find solutions without having to post the same issues over and over again.