Drag and Drop Images in Firefox Blank page

Yep like the subject can’t figure out why I can’t drag and drop jpeg images from Dolphin to Firefox.
I get strange error.

Windows 7 side no issues dragging and dropping images to Firefox.

Thanks! :smiley:

I’ve never tried that. But then again, I don’t care for much for Firefox and remove it first thing, along with Thunderbird, Skype, etc. :wink:

U…U…u Don’t use Them? That…That’s Blasphemy! :stuck_out_tongue:

Nope, never have. I prefer Chrome / Chromium, most everything I do is web based and on google services anyway (G-mail, G+, hangouts, etc). Makes it easier to sync my pictures, etc. between my PC, phone, tablet and G+ account.

Anyway, I was thinking about this and the KDE extensions and add-ons to Firefox were originally written for kdelibs4.
Have you tried draging and dropping from dolphin4 into firefox yet?


Did you tried dragging into the adressbar?

Yep and get this in address bar.


I Think the Chinese R Watching Me! :s

Posted in the KDE reddit and this was one of the responses.

May I ask what are you trying to drag the image file into exactly (e-mail, forum post, etc.)?

Drag-n-drop in google chrome from dolphin has a crossed out circle and will not drop.
Using dolphin4 however, chrome will load the picture into the new tab.

Like I said before, it might just be a kdelibs4 vs kf5 issue.
Open dolphin4 and do the drag-n-drop again from it.


Yep running Dolphin4 returns to normal behavior of displaying jpeg in browser.
So looks like a transition thing.

Thanks for pinning it down for me.

No problem, we just need to wait for firefox, chrome, etc. to talk with kf5 based applications. :wink:
I know Firefox doesn’t since it reads kdeglobals from the old kde4 location to determine if it’s set as default browser.
This is why in Netrunner Rolling I have ~/.kde4/share/config/kdeglobals as a symlink to ~/.config/kdeglobals.

This actually solves the same problem for kdelibs4 applications under Plasma 5, as it does for frameworks applications under KDE SC 4: