Error Message when running updates.

Opened Synaptic
clicked “Reload”
clicked “Mark All Upgrades”
clicked “Apply”
clicked “Apply”

Got the following error message:

E: /var/cache/apt/archives/qtvirtualkeyboard-plugin_5.7.1+dfsg-1_amd64.deb: trying to overwrite ‘/usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/’, which is also in package qtvirtualkeyboard 5.7.1-0neon+9+build5

E: /var/cache/apt/archives/qml-module-qtquick-virtualkeyboard_5.7.1+dfsg-1_amd64.deb: trying to overwrite ‘/usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/VirtualKeyboard/Styles/’, which is also in package qtvirtualkeyboard 5.7.1-0neon+9+build5

Anybody have any ideas on how to fix this?

Sounds like a packaging issue between the neon and debian repositories. Looks to me as if the debian repository has somehow been raised in priority over the neon repository. Hopefully one of our Debian version support staff will be able to help you fix this.

Can you run sudo apt-get install -f in a terminal to identify the package that is causing the issue.
Also just out of curiosity did you change your repositories somehow? (added or activated other repositories that don’t come by default)

When I run “sudo apt-get install -f”, I get the following:

tony@NR-U56E:~$ sudo apt-get install -f
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

When it comes to repository changes, quite a while back I followed the instructions for enabling continuous updates which basically had me select all of the repositories that were not selected.

I had also installed Oracle Java, which is why the Webupd8team was added. I am not sure that this was the proper way to go about that in Debian. That is how always did it with previous versions of Netrunner that were Ubuntu based. If there is a better or different way to go about this on the new Debian based Netrunner, please advise.

I also had previously installed Opera browser which added that repository.

I have run updates countless times since making the changes mentioned above without any issues. The problem started when during a recent set of updates, it is trying to “Install” “qtvirtualkeybord-plugin”, and “Update” “qml-module-qtquick-virtualkeyboard”

Just Yesterday I had a problem with VirtualBox not working due to vboxdrv not existing so I reinstalled it and that is when that repository was added. Again the problems with the above mentioned updates were happening before that as well.

I have attached print screens of my repository list, and the screen that shows the changes that synaptic was trying to make. The Highlighted Repository on RepoPage2 was the last repository on RepoPage1. Hope this helps.




I also have this problem, any way to fix?

Same Problem but no help provided, seems no one cares :dodgy:

You can force overwriting the files with

sudo dpkg --force-overwrite -i /var/cache/apt/archives/qtvirtualkeyboard-plugin_5.7.1+dfsg-1_amd64.deb


sudo dpkg --force-overwrite -i  /var/cache/apt/archives/qml-module-qtquick-virtualkeyboard_5.7.1+dfsg-1_amd64.deb

if you need the virtual keyboard.
Seems like debian is conflicting with our Netrunner packages here.

That worked.

Thank you very much.


@Leszek: Thanks, it worked for me!

This should properly be fixed now :slight_smile: