Back to Netrunner | Back to Blue Systems

Ethernet disabled

Hello,

Ethernet is disabled. Sometimes it is getting active but only in AC. Is there any special configuration for that?

When you say Ethernet, you do mean the corded connection?
That should not be an issue, but you could check to see if the tlp settings are causing your issue.

Yes. Tlp settings? But I haven’t changed anything from the initial installation. The network manager for the most of the time doesn’t show the wired interface at all.

ip link shows:

enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
link/ether 38:63:bb:b5:a2:51 brd ff:ff:ff:ff:ff:ff

If I boot on AC, the problem is solved. It seems that something happens when it starts in battery.

I don’t maintain the tlp package, this comes from upstream.
Manjaro has made some default settings changes to TLP recently.
Try disabling the tlp service and see if that fixes it.
If it does then you may need to troubleshoot and/or configure tlp for your system specifically.

There are many things that can cause these kinds of issues, especially when you indicate that NM “most of the time doesn’t show the wired interface at all”.

Do you dual boot with windows?
Did you suspend or hibernate your system, or was this from a completely powered off state?
Do you have Wake on LAN enabled in the systems firmware?

This could be also be caused by a software switch that enables the LAN interface on the system, your chip set module (drivers) themselves, or even a bug in network manager.

Could you please post your machine specs: inxi -F

Today I had an update of the tlp package. It seems fixed for now. I will monitor this issue and I will inform the forum if the problem remains.

I’m glad to hear the latest update fixed your issue. When you feel comfortable enough about this issue being resolved, could you please add (Solved) to the beginning of the original thread posts title.