External monitor flickers in x64 version - GeForce card

Hi fine people, I’ve been struggling with an issue fro almost a week now.

I installed the x64 version of Netrunner on a MacBook Pro, Intel i7 8 processors (after dealing with EFI, etc). Works really great, but when I connect an external monitor via mini DVI->VGA connector the screen flickers in the external monitor. Doesn’t happen with every application, but Dolphin is at least unusable. The flicker sometimes is so terrible that the plasma process crashes (so it says in the description)

I tried the third party NVidia drivers (all of them) with no avail (restart and everything in between)

Then I installed Ubuntu Studio and Linux Mint in another partition to see if it was a driver issue or a cable issue, etc. Both work perfectly well fro hours with absolutely no flicker.

Then I tried Kubuntu, and bang, same issue. So it seems to be related to KDE itself. I’ve tried disabling the desktop effects and basically tweaking all of the options I can see from the settings screen, but no avail.

Finally, the Netrunner x32 bit works almost perfectly but still there is a minor flicker from time to time though it is more usable than the x64 version.

Any suggestions? I really really want to be able to keep Netrunner but the x32 version does not cut it anymore because I use very intensive image manipulation programs and the memory management is giving me problems in x32.

Thanks in advance for any hint, this is driving me crazy.

Did you also tried disabling the desktop effects?
Did you also tried it without installing any nvidia drivers so with the default driver?

Are you absolutely sure that this is actually a KDE issue?
Have you tried using any other KDE based systems besides Kubuntu/Netrunner?

If not then could you try the Netrunner Rolling and/or Manjaro KDE edition, how about the KDE version of Linux Mint, Fedora, Suse or even Debian?

My point is, this could still just be a configuration issue and not the fault of the DE.

Hi leszek, yes I tried disabling effects and all the drivers (some old ones actually crashed the system). Same results

Hi AJSlye, thanks for the suggestion, I just tried Manjaro and Linux Mint KDE and the problem still persists, though in Mint is is not as annoying as with Netrunner. I also noticed the flickering seems to trigger more noticeably when something GTK related is involved. For instance in Mint if I use the OxygenGTK theme for GTK apps it seems to work much better (almost flawlessly) that with any other GTK theme.

But apart of that I’m still stuck.

What chip set is on your Nvidia adapter?

This is what is listed in my system (Macbook Pro retina):

VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition] (rev a1) (prog-if 00 [VGA controller])

So it’s a hybrid graphics system, what mode do you have it set to in the EFI?

How do I check that? Sorry if the question seems dumb, I really don’t know much of low level MAC settings.

Can you give me the output of inxi -G?

Here you go:

inxi -G:
Graphics: Card: NVIDIA GK107M [GeForce GT 650M Mac Edition]
X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1440x900@59.9hz, 1920x1080@60.0hz
GLX Renderer: GeForce GT 650M/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.38

OK, so you have the Intel chip disabled.

Since your using the nvidia drivers you don’t want to use the KDE screen setup utility but the Nvidia control panel.

Also, make sure that if you’re connecting the external monitor to HDMI then the resolution should be 1920x1080 and set to Ultra HD, HD or SD and not PC.

Do you know if there is a way to enable the Intel chip only? (by the way I’m using a DVI to VGA converter from Mac, my external monitor does not have HDMI)

Interesting thing, I use the NVIDIA X Server configuration app and the flicker is still there. Even if I use the open source driver the flickering is the same, so it looks like the NVIDIA drivers don’t make any difference.

Here’s a predictable behavior: If I open Eclipse, when using the OxygenGTK theme for GTK2 apps, it does not flicker when moved to the external monitor, but if I change the GTK2 theme to anything else the flicker gets so bad that the screen goes black. This is in Linux Mint KDE 64 bit. Netrunner is almost unusable in the external monitor.

So am I getting this right, QT apps don’t flicker the screen but GTK 2 & 3 apps do?
or is it just one or the other?

Do you have ia32-libs-gtk installed?

Another thing to try would be to use gtk-qt-engine instead of the GTK 2 theme itself.

Well in Linux Mint 17 KDE it looks like QT runs well, but GTK apps using other GTK themes besides OxygenGTK flicker. However, on Netrunner 14.04 x64 even dolphin flickers badly out of the box (and even after running the updates, with any video driver).

On any Linux with GNome based desktops (that I’ve tried) the flickering is zero.

Maybe I’m wrong, but I think ia32-libs-gtk are out of the ubuntu repos since multi-arch was introduced, I learned this when I tried to setup skype last year when 13.04 came out.

How safe is it to install the gtk-qt engine?

By the way, I really appreciate your follow up and the time you put on this this thread.

The gtk-qt engine should be fine to run on KDE SC 4.14.xx, however might not be an option anymore once Plasma 5 becomes the default DE.

I tried to search for gtk-qt-engine but it is not even available in the repos, then google search tells me it is not in development anymore and quite old. But still I might give it a try, however how do I install it?

I apologize, it seems that gtk-qt-engine is no longer available for Ubuntu based systems. You could try using the one built for sid but I’m not sure how that would work out, I have not been much of a Debian/Ubuntu guy in quite few years.