Flash crash in browsers

Hi!

First of all I would like to apologize, if there is already a thread concerning this problem, though I couldn’t find it with the search.
Second, is that I’m very new to Linux. So, if anybody can help please, do it in a step-by-step way, for I am/was using Windows most of the time in my life. Although before using Netrunner I checked LinuxMint on a Virtual Machine, and I quite liked it, but I had some problems with it. Since then I tried some other Linux distros, but I didn’t enjoy them as much as Netrunner.
Third, let’s see the problem:

Anytime I want to check Youtube or other sites that using flash in my browsers (Opera, Firefox) the flash plug-in crashes. I googled the problem, but I could only find some old Manjaro Linux forums where the users solved this problem by downgrading their video driver.
Now the question is: is there any simpler way to solve this issue in Netrunner? Or if there isn’t, can anyone help with a step-by-step guide how to do that?

I installed and updated successfully the new Netrunner 14 on my Desktop computer. This computer has the following specs:
Motherboard: Abit NF-7S
CPU: AMD Sempron
Video Card: Nvidia GeForce 6600
RAM: 1,5 GB

Thank you in advance for your reply!

The issue your having could be an issue with your display drivers and hardware acceleration in FF.

Are you using the nvidia proprietary drivers or the opensource drivers?

I don’t know what kind of drivers I’m using. What is more I don’t even know where to look for that to tell you… :huh:

On a new install the open source drivers would be default, to be sure you’ll need to open up Software & Updates, then on the last tab (labeled Additional Drivers) is where you can verify and mange what drivers are loaded at boot time.

Finally I found that tab. That Software & Updates tab, for it didn’t show up anywhere, was in Synaptic -> Settings -> Repositories.
It says that “There are no proprietary drivers in use.”, and the round checkbox checked next to “Using X.org X server”. I surmise I should change to something else. Well, I changed it to a tested Nvidia binary driver (ver 304.117). It still “working on it”. Is that normal? Or I shouldn’t have chosen that?
[hr]
Update:
I don’t think it’s doing anything for there’s no Disk or CPU activity. Trying another driver…

Well it seems it doesn’t have any effect since I chose the driver and applied it, but still nothing happening. It says that “applying changes”, but that bar doesn’t move at all, and in Krunner no CPU usage shown for the synaptic or for Software and Updates…

I don’t have an Nvidia machine to test.

Have you refreshed the package list first and are you connected to the internet while doing this?

If not then this is the issue, it has to download the packages to install them.

As you’ve suggested the problem was that I had to download the packages is first. Now I’m using tne Nvidia driver, but the Flash still crashes. What is more my Desktop effects ceased to be. Not showing the cube when I cycle through my virtual desktops, and even the 3 dimensional cube effect, that I set to the top left of the screen, doesn’t show up either. Oh, and while it installed the Nvidia driver it uninstalled the WINE that I installed earlier; I don’t know why.

I was looking on the net for solution for that, but my search yielded no success. Is that possible that this Nvidia Card is so old that it is not supported? At least to view flash content with it…

No it is not the graphicscard. This one is pretty new.
I guess the problem might be the sempron processor. The official flashplayer by adobe needs an SSE2 capable CPU.
You can check if your CPU has SSE2 by executing

cat /proc/cpuinfo | grep flags

This will give you a list of supported standards. If you don’t find sse2 here that might explain while flashplayer crashes immediately (basically it can’t be started)

The last release from adobe that supported these older processors is flashplayer 10. But I will not provide a direct link to it as it is security wise outdated and I would not recommend using it.

No need to check, the Abit NF-7S is a socket A motherboard, there are no socket A Sempron processors with SSE2 instructions, you can not run the latest flash with this processor: http://en.wikipedia.org/wiki/List_of_AMD_Sempron_microprocessors

Well, I suppose in that case that’s it, no solution. Thank you for your time finding this out for me!