back to Netrunner | back to Blue Systems

Gamepad on non steam games?


#1

Hi everyone.

I installed Netrunner 17 as an alternative to Kubuntu and I must say that I like it a lot, but I have a problem with my xbox controller. When I play a game through steam, the controller works perfect, but if I play a non steam game, from gog for example, the controller is not recognized inside the games.

It’s very weird, I have the game Limbo through a humble bundle purchase so I have it in my steam library and also a version without drm in which I don’t need to use steam to install it.

If I run Limbo from steam, the controller works.
If I run Limbo from Humble Bundle, the controller doesn’t work.

But the more strange thing is that if I run Limbo from steam through Wine (or PlayOnLinux), the controller doesn’t work too.

I also tried the mame emulator and the controller works with the roms, but as I said, games from gog or humble bundle like Shovel Knight or UnEpic (and people in the forums doesn’t have my problem) or Steam games through wine doesn’t even recognize it.

Did someone know what could be the problem and a possible solution that doesn’t require to reinstall another distro?

Thanks in advance.


#2

Have you checked the “Joystick” section in KDE System Settings -> Input Devices ?

As for myself, for many games I use a keyboard-to-gamepad mapper called QJoyPad
http://qjoypad.sourceforge.net/
I should be available in the repos, though I don’t know how it works with more modern gamepads (with vibrations, touch surfaces etc.)

If you’re not afraid of the Console and the System Files, you may look for information at ArchLinux forums. This community advanced the art of workarounds to a level unseen in any other Linux community :slight_smile:
https://wiki.archlinux.org/index.php/Gamepad