Getting Netflix To Run...?

i got wine to run on the 64 bit version and tried installing the Netflix desktop without success. I got this error message:


It appears that you do not have extended file system attributes enabled.
Please enable the user_xattr option for your filesystem and try again.


the error comes up after clicking on Netflix icon in the menu.

I even tried installing Pipelight and following someone elses advice and nothing worked. Even tried editing the file, but no change.

Hi Jakk, did you follow this tutorial?
http://ubuntuhandbook.org/index.php/2013/08/install-netflix-desktop-app-0-8-in-ubuntu-13-10-13-04-12-04/

Yes I did. I even went further and installed Pipelight after the initial updates didn’t work along with a few other things.
But that message kept coming up every time i would try to start Netflix. I did install it on Zorin-OS without a hitch.

When does the error message show up?
Can you make a video so we can see what happens,.

I don’t know how to do a video. But it shows up maybe
3-5 seconds after clicking the Netflix icon in the menu.

Here is the full tutorial. You need the xattrib support (extended file attributes) as it seems. This is disabled by default in ext filesystems because its implementation there is a little bit wanky.
http://ubuntuforums.org/showthread.php?t=2084592

I tested this on 64bit RC install and Netflix did start fine.
I couldnt test any video, because of country restriction, but it did start up without error.

I just tried this and it did NOT work. Same message appears right away after clicking Netflix icon in the menu.

But one thing… it says to add the line of code to the fourth column. There are NO columns! There were three lines of code, so I added the additional line of code to the fourth line.

Can you post the content of your /etc/fstab please.

overlayfs / overlayfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0
#Added Line
UUID=94f7fc1e-fa27-4b24-99f3-4b461665a4a4 / ext4 errors=remount-ro,user_xattr 0 1

I also copied the code from Zorin-OS and cut & pasted it in and still got the same prompt.

It appears that you do not have extended file system attributes enabled. Please enable the user_xattr option for your filesystem and try again.

I then added the recommended line to the Zorin code to see if anything would change and nothing changed.

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/sda1 during installation

UUID=00443fcd-6706-4b4a-acef-2465b9bb255a / ext4 errors=remount-ro 0 1

swap was on /dev/sda5 during installation

UUID=5386a6c1-959b-4e1b-b92b-635f64d64c4e none swap sw 0 0
#Added Line
UUID=94f7fc1e-fa27-4b24-99f3-4b461665a4a4 / ext4 errors=remount-ro,user_xattr 0 1

Even tried installing redbox using synaptic and it says it’s installed though I cannot find it anywhere!

Does this mean anything to you?

http://ubuntuforums.org/showthread.php?t=2174721