GPT woes

Hi guys - LOVE the new rolling release and have been happily running it in a VM but now I have a little problem. I have a brand-new 3GB hard drive and apparently I need to set up a GPT partitioning table in order for the whole hard disk to be seen/used. I have never used GPT before and assumed it would work ok. I began installing the new 64 bit rolling release but had an error that the installer couldn’t set up partitions (I assumed because it wasn’t GPT) so I manually created a GPT table, tried installing and had the same error. I then manually created root and home partitions, started the installer again and chose manual partitioning, selected the right partitions and mount points, installed, rebooted and got a black screen with a blinking cursor. I ran the live CD again and tried to manually install grub which failed saying something to do with the partition table being GPT and not being supported in the BIOS. Can someone please tell me how to get this working - a step-by-step, newbie friendly guide would be great. I’m sure if the table was MBR it would be fine but as I said GPT is a completely new concept to me. Please help!

Thanks guys

Read this from the Netrunner rolling release note.
http://www.netrunner-os.com/readme-1312/
As I understand it, you need EFI enabled to use GPT, BUT THE README says to disable UEFI??
Also make sure Secure Boot is disabled.
I also found this link about Arch and GPT: https://wiki.archlinux.org/index.php/GUID_Partition_Table#UEFI_systems
I wish I could help more but I haven’t tried GPT yet. One of these days I’m going to try GPT and using EFI, but my current setup works fine with the old dos partitioning scheme.
Hopefully, someone who has set it up will help you.

Just a note: The readme link above is for 13.12 Standard Edition, not Rolling.

You need only disable secure boot, not EFI to install Rolling.

Thanks, but it was there when I clicked on the Rolling download link.
Good to know.

Do you know where you clicked, then it is wrongly linked?

It’s here at the bottom on the left side: http://www.netrunner-os.com/download/
You are right, it does talk about the regular release, but it’s on the rolling side.
Kind of confusing, but it is talking about 13.12 regular.

I’m not using EFI or secureboot, before this I was using a normal MBR set up but since I bought a 3TB hard drive, I have to use GPT and I just can’t seem to get it to work. Any ideas?

I did some searching and it seems if you are useing a 3TB drive as a boot drive, then you must use EFI.
Without EFI you are limited to a boot drive of 2.2 TB.
Again I am not using any drive above 1TB, but that’s my understanding about boot drives your size.
You might check with the comapny that made your mother baord.
Secure boot causes problems but I don’t think EFI is the issue people think it is.
I’ve enabled EFI and had no problems booting Liux dsitros.
I belive EFI is an improvment and it’s here to stay.

I also have a GPT partition, but only 1TB hard disk. Netrunner Rolling grub, does not install directly, so what I did initially was update grub on the ubuntu partition. I multiboot, with ubuntu 14.04, netrunner rolling and windows 8.

But After reading your post, I remembered having the same problem with Burg on GPT. I used the force command.

So follow these steps from here on reinstalling
Manjaro wiki

but for[quote]grub-install /dev/sda[/quote]
replace with [quote]grub-install --force /dev/sda [/quote]
I didn’t have to follow the UEFI section , but making EFI /boot/efi directory doesn’t hurt either, and I know that method also works, I did it on Ubuntu.

Do not forget to follow the two commands, after reinstalling grub, especially

And I have tried it currently on my install, it worked without breaking anything, so don’t be alarmed.

Wish you luck.

Got it sorted, I didn’t realise I needed a bios-boot parition (33MB in size, formatted to EF02).

That is good to hear, having a bios/boot partition is handy, as that is the way it should be done.