Graphic driver amdgpu causes black screen


Thank you for making this useful and beatiful distro and your support so far :D.

After the 2016.01 iso came out, I can’t run netrunner in my pc.

I mean, I manage to login sometimes and the system works but usually the screen shuts off completly after the plymouth screen. Right after the “Starting systemd version 229” message. Then the Caps lock light blinks.

My laptop model is Dell Inspiron 15 5545. Here is the output of “lspci -k” from the live system:

I have currently installed kernel 4.6.2. Before amdgpu it used to work. I tried removing /etc/X11/mhwd.conf and also removed xf86-video-amdgpu package, with no significant difference.

KDE partition manager reports SMART Status as good for the hard drive.

You have two AMD GPU’s One is using the radeon driver and the other is using the amdgpu driver, I’m not sure if this is possible ATM.
Try installing the proprietary catalyst driver as these should work with this combo.

Thanks for the suggestion, I will try it.

An update, catalyst bricked the system. I tried kubuntu and although amdgpu worked, I got kernel panic efter a while. I think the problem with netrunner could be bad installation. Because the screen dies after plymouth even if I blacklist amdgpu from the grub command line. I will either try Netrunner 17 or the next rolling release, any suggestion?

A blinking caps lock would also indicate a kernel panic.
Can you provide the journalctl output? In the most recent I managed to login to DE, while the other failed.

If both the catalyst drivers and the opensource drivers are crashing the system then the GPU itself may be bad.
But first, lets see if you just need a newer kernel series for the amdgpu driver and that card.

sudo mhwd-kernel -i linux46 rmc

I already have the latest kernel, I fixed my problem by blacklisting amdgpu and rebuilding initramfs.

I’m glad you were able to fix your issue.
Here is what I’ve found out in the meantime.
MHWD, the Manjaro Hardware Detection software, was detecting some GPU’s as compatible with the amdgpu driver that in reality were not.
The update on 2016-06-11 should have fixed the issue:

A simple re-run of mhwd should also fix the issue.

Ok I runed “sudo mhwd -a pci free 0300”, thank you for all the info :slight_smile: !