Grub error ?

i just installed Netrunner 14 and i get grub error after booting with netrunner UEFI menu.
it display grub 2 command line “Grub>”
i intalled kubuntu 14 before with no problem.
i use GPT disk and clover Bootloader.

I don’t know clover bootloader but isn’t it able to boot linux directly?
Do you have secure boot enabled in UEFI? Note that you need that disabled for it to successfully boot.

The last thing you can do to help us analyze the error is sending us the installer log from the installed partition in /var/log

secure boot id desabled.
i think the problem is not clover bootloader, in UEFI bios bootmenu i can found Netrunner entrie
but when i select it i get grub command line.
i dont have this problem when i have installed kubuntu, opensuse or fedora.
trying boot-repair without success.
the only way to boot netrunner is to select vmlinux entrie from clover bootloader.
i attached installer log file.

As I don’t see an error in the logs I can only suggest you could try this for example:

As the logs clearly indicate that grub is installed successfully and the menu for it was populated (even with the windows boot entry) this is the only thing I can imagine that it somehow does not find the grub.cfg file.
You need maybe to search your grub.cfg file on (hd0,1) or (hd0,2) or the partition you installed Netrunner onto.

thank’s for the replay.
I mounted Efi partition in windows 8 and i found that Netrunner is installed correctly :
folder “netrunner” contain files :
the content of grub.cfg is :

the partitions of my GPT hdd hd1 (second disk):
sdb1: windoes recovery
sdb3: HFS
sdb5: SWAP
the EFI partition is in the first disk : sda2 (i select that partition for grub when installing Netrunner).
i attached grub.cfg from /boot/grub

Same error after several tries, 2 different computers, both single or dual boot. Even changing the boot manager.
Clean install of netrunner 14.1.
The only way to install properly is disabling completely UEFI.
No problems at all with Mint or Ubuntu

Waiting for a fix for netrunner grub install for UEFI bios, the manual sollution is :
1.) Insert and boot your Netrunner installation media.
2.) Create the /boot/efi directory
sudo mkdir /boot/efi

3.) Mount the EFI partition as /boot/efi
sudo mount /dev/sdXY /boot/efi

X = Alphabet of the drive = a,b,c … Y = Partition number of the EFI partition = 1,2,3,4…
Example - /dev/sda4

4.) Re-install Grub.
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=netrunner --recheck

5.) Update Grub configuration file.
sudo update-grub

Maybe is a newbie question but in step 2 you’ve said:

2.) Create the /boot/efi directory
sudo mkdir /boot/efi

But the dir is already there, with all the efi files. Do I have to delete the dir?

do not delete it if exist just mount it .

As you-ve said for the step 4>

4.) Re-install Grub.
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=netrunner --recheck


grub-install: error: /usr/lib/grub/x86_64-efi/ doesn’t exist. Please specify --target or --directory.

I-ve looked for x86_64-efi in both USB and HDD but isn-t there. Where I could find it?

there :

Is this bug is already fixed? I have the same problem on 2 laptops with the new system installation.
If not, how to properly install grub-efi-amd64?

As the bug is still not located (we use the same ubiquity upstream uses) we do not have a fix for it.
So it should just work.

This is how to fix the error:
grub-install: error: /usr/lib/grub/x86_64-efi/ doesn’t exist. Please specify --target or --directory.
From Saturday I can not get install the system by an error in the grub.
Kubuntu 14.10 In the absence of this error. Grub is ok.

Does anyone have a solution to install grub correctly?

Hey guys!

I’ve just registered in the forum because I love Netrunner and I also know how to fix this bug.

This is one of those bugs that it’s “in your face” but we just don’t see it straight away. This problem is caused by the fact that the UEFI path for the grubx64.efi file is hard coded to be /boot/efi/ubuntu, and Netrunner renamed the folder to “netrunner” causing an issue with grub.cfg not finding the correct path for grub bootloader.

So the fix is this:

  1. Install Netrunner in UEFI mode as you would normally, with an UEFI partition and GRUB set to install in /dev/sdX
  2. After installation finishes, press “Continue testing”.
  3. Open your terminal and type this commands:

sudo mount /dev/sdXY /boot/efi (mounts the EFI partition, replace XY with your EFI partition path)
sudo dolphin /boot/efi (opens dolphin window with root inside the EFI partition)

  1. Get inside the EFI folder and you will see a folder named “netrunner”. Rename it to “ubuntu” (with all lower case letters).
  2. Close dolphin, reboot, and you should now be able to boot into Netrunner just fine.

Now if any of Netrunner’s developers is reading this, please pay attention to this bug. Do not change the name of the UEFI folder to “netrunner” because grubx64.efi is coded to “boot/efi/ubuntu”. If you really want to have the folder named after the distro, make the changes to grubx64.efi and grub.cfg to fix it (I DO NOT RECOMMEND THIS). If you don’t check this, the bug will continue to ship with future versions of Netrunner.

Elementary OS Freya was also having this issue and on their recent Beta released yesterday, they fixed it by leaving the folder named “ubuntu”. Linux Mint also names the folder as “ubuntu” and never had issues on this regard.

Thanks for reporting on that issue. That is a great help to fix the bug.
Now we only need to find out why the folder is called ‘netrunner’ as we didn’t change its name as far as I am aware of.
It seems to automatically generate this folder name.

It must be a script in the grub-efi-amd64 package. Ubuntu has modified the GRUB scripts to adapt to his installation and there’s prorably one script that identifies the EFI path and names it after the distro.
You may give a shout to the Elementary team as they found a way to fix the issue in their recent Beta, so they may know how to counter the folder renaming issue and where’s the script that does it.