Netrunner Home

Grub update after install with no effect


#1

Hi,

I installed the latest rolling version on one of my disc partitions. On the same disk, I have Windows (before) and Ubuntu (after). The issue is the following: at the end of the installation, when the system reboot, Netrunner was not visible at all (I can start on Windows or Ubuntu).

OK, not a big deal: I booted on Ubuntu, run update-grub and restarted. Then, the option to start Netrunner was available.

But is seems I have an issue to update grub FROM Netrunner. If I run update-grub from Netrunnger, all messages are OK (all boot options found). The file /boot/grub/grub.cfg is modified (at least its modification date is updated). But this has NO EFFECT on the menu of Grub at the boot. Typically, I can change the default line to be selected, but this won’t have any effect. The only way to change Grub is to reboot into Ubuntu, modify options there and run update-grub from Ubuntu. My issue is that I want to erase Ubuntu… but if I do that, I will then loose any possibility to modify Grub…

Does someone know why I can’t update Grub from the NetRunner instllation ? What could be a way to solve this ?

Best regards.


#2

Just like Manjaro, Natrunner Rolling uses special boot images to load the Intel/AMD microcode prior to loading itself, thus grub has to be updated from within Netrunner,
https://wiki.archlinux.org/index.php/microcode

Modifying grub from within ubuntu or any other non-arch based distribution will definitely mess up grubs ability to boot into Netrunner Rolling. The best solution would be to boot the Netrunner live media again, and use it to fix grub.
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

If you have an AMD apu/cpu, please read the following announcments:
https://forums.netrunner.com/showthread.php?tid=24601
https://forum.manjaro.org/t/stable-update-2018-08-31-kernels-mesa-qemu-nvidia-firefox-python-haskell/56864/2


#3

Well, in facts I simply didn’t realize that I needed to do grub-install before update-grub because until now, I always had the grub already install and I only needed to update it… so forget my question which was stupid: a simple grub-install solved the issue…

Cheers.


#4

That’s :cool:.
However, there are no stupid questions. :wink:
:smiley: