Grub2 failed to install

i’m writing now frum usb live, and i have runned install netrunner 14.1 LTS but after the installation it’s finished when it’s installing grub on dev/sda2 it says fatal error installing grub, Executing grub-install /dev/sda failed, this it’s a fatal error and if i reboot it enters in grub2-rescue what should i do ? Thank you PS: I’m trying to install frontier on my SSD

dev/sdb1 ext4 107.8 GiB
/rofs squashfs 1.4 GiB 0.0 KiB
1.4 GiB
Others ntfs 58.6 GiB
Stuff ntfs 174.3 GiB
NETRUNNER14 vfat 3.7 GiB 2.3 GiB

The SSD have the Linux, the Others and Stuffs that are ntfs are under Windows. atm i don’t have Windows installed in my PC and i’m running netrunner from the usb. The /dev/sdb1, rofs are the partitions where netrunner it’s installed, at this stage if i reboot and i try to boot from the SSD it appears a grub2 window where i most enter the commands to boot it, i typed boot and it say’s that i most select kernel first. I have installed and runned gpart repair from ubuntu

Please paste (use quotations or a nopaste service) the installer log from /var/log to see what concrete error grub is spitting out.

PS: Also are you using a mbr/dos partitioning scheme or gpt ? Are those partitions all primary partitions ?

PPS: Did you do what was suggested in the last sentence from here ?

I’m using GPT partitions, i have runned the shortcut from desktop with install netrunner and i have choosed to install it on the entire disk that it’s an SSD Kingston, the syslog is here

He added a file, looks like he has GPT.
The /dev/sdb1 where he has his frontier installed does not have a boot flag

Look for yourself:

Maybe you can walk him through fixing this, I have to hit the hay, I haven’t slept yet and it’s already 7:20 am here. :slight_smile:

Thx Aj .

@swaMP During install you need to choose as grub install target /dev/sdb or /dev/sdb1 and not /dev/sda2. (which is your ntfs partition)

I would recommend choosing /dev/sdb though as your ssd (/dev/sdb) is using mbr and not gpt like /dev/sda is.
Also make sure (in kde-partitionmanager) that the /dev/sdb1 partition is marked with the the boot flag.

Thx @AJ
Thx @lsezek

Guys, i didn’t know because i have booted the usb-live and selected install from desktop, and choosed the auto part. Now my question is how i make mbr and not gpt ? with gparted or gdisk ? Thank you for helping me guys, i’m really thankful for helping me cause my homework is still waiting for me :smiley:

Just as I said during the installation you can choose where to install the bootloader and choose the /dev/sdb drive. I would leave it on mbr though if you only have one or two partitions on it (not more than 4)

Ok, now i have seted up the bootloader to /dev/sdb and created the partition and now what option to choose ? Guided resize , guided use entire disk ?

Just do it manually and setup a / partition with ext4 and a /home partition with ext4 all on /dev/sdb. And I would also recommend to have at least a 2 GB swap partition (depending on your RAM though. If you have 16 GB RAM you don’t need swap)

Is it ok how i have done ? [attachment=585]

4 GB Swap is a little bit much but it looks ok to me. Don’t forget to mark the /dev/sdb1 partition and click on change and set the mount point to / (and filesystem to ext4 if it default to not using) .
After that you are good to go.

Ok and i install it in /dev/sdb or /dev/sdb1 ?

Device for boot loader installation /dev/sdb

Device for bootloader installation should remain /dev/sdb

ok, and where to install netrunner ?

On /dev/sdb1 that you set the mountpoint to / already. Didn’t you ?

This is ok ? Or i need to install netrunner in the /dev/sdb where mountpoint is set to / ?


In this dialog you need to set Use as ext4 and set the mountpoint to /

Related to this problem:
I was running Netrunner 14 successfully and attempted to use the script to upgrade to 14.1 – Huge mistake!!! I gave up trying to sort out the resulting mess and cleared the root partition and installed 14.1 from a DVD (down loaded and burnt using k3b. This DVD successfully installed on my ASUS desktop (big installation 6GB Ram and 1.4TB of disc), an old Toshiba laptop and a recent Lenovo Flex-11. However installing N-14.1 onto my new Lenovo Flex 2-14 has been another disaster except it almost works. Grub seems to have been only half installed. Booting results with an immediate “grub>” prompt. The command “set” shows “prefix=(hd0,gpt2)/EFI/ubuntu” whereas it should be “prefix=(hd0,gpt8)/boot/grub”. After searching the Internet, I find that Grub2, UEFI and gpt is an unholy mess with problems cropping up in lots of places; as a result I eventually tried:

set prefix=(hd0,gpt8)/boot/grub
set root=(hd0,gpt8)
insmod normal
This routine is a pain in the proverbial. I found eventually that “> set prefix=(hd0,8)/boot/grub \ > normal” would suffice. One snag was if there was an SD card or an USB disc plugged in hd0 became hd1!
I have tried installing N-14.1 both from an USB disk and an USB CD with identical results.
Grub2 consists of too much Black Magic for me to figure out why it cannot get prefix right. The crucial line in /EFI/netrunner/grub.cfg is “set prefix=($root)/boot/grub”. Clearly, the original ‘prefix’ was wrong. Unfortunately (hd0,2) is a FAT system, so I cannot put in a soft link from ubuntu->netrunner.
What is the official fix for this.
The rest of the installation is pretty good: the touch screen works as do the USB sockets and thr SD card.
Then using synaptic I automatically perform an update, whereupon almost everything stops working after the next reboot. (update results in a new kernel (3.0.13-49 in stead of 3.0.13-43) and 600 odd other updates. After the reboot,
The screen is no longer a touch screen and none of the USB seems to work and the touch pad is a bit primative.
I have been through this process with both the 64-bit edition and the 32-bit edition with almost identical results.


32bit should in general not support uefi at all. This whole uefi32bit stuff on some macs is a whole mess of other new problems.

As for 64bit UEFI especially with secureboot enabled it is a Microsoft nightmare.
Microsoft forced this stupid technology upon us. I can only recommend to disable secure boot and use whenever possible the bios compatibility mode.
This stuff is so old that it just works without any magic spell or crossed fingers