grub2 fails to boot netrunner [solved]


I just installed Netrunner 14. The installation went fine and I left the defaults for the boot loader, i.e. install to /dev/sda. I have EFI booting and have /dev/sda1 set up for EFI and boot and /dev/sda2 for / (actually Netrunner does that for me). However, when I go to reboot I am brought to the grub2 boot loader. I have spent several hours on this and have tried:

among others. And yet I still can’t get grub to boot Netrunner.

This seems strange to me as it works completely fine with Kubuntu.

Thanks for the help in advance!

OK, after spending the better part of 4 hours on this, it turns out it had to do with a bad copy of the ISO to the usb. I used the usb-creator-kde from Kubuntu and it ended up giving me a bad image. So, I copied the image with the dd command. I would recommend people do this before messing around with grub for hours, just in case …

Also, if others have issues with usb-creator-kde then I would strongly recommend removing it here:

Typically, I don’t use usb-creator-kde but because it was recommended there I did.