Guest Netrunner goes black (VMWare) [solved]

I’m new to Netrunner. I’ve tried 3 different machines to run Netrunner 20.01 guest on VMware workstation 15.5.1 on Windows 10 host. When I maximize a window then minimize it, Netrunner goes black immediately, can’t do anything more. Has anyone got this problem? Is there any solution?

So to clearify it boots just fine but as soon as you minimize something on the desktop the screen of the VM with Netrunner gets black?

It sounds like an issue with the compositor. Try to go to systemsettings and search for compositor. Set it to use Xrender instead of OpenGL and see if it helps.

:smile::smile::smile:Thank you, it works.:+1::+1::+1:

yes that seems to resolve “nothing paints” yet I note window borders and window toolbar don’t paint until I interact w some other window.

I have little experience w VMware, so I’m not clear how to establish “sanity conditions.” eg, I installed VMware Tools and now the display settings no longer persist after reboot.

The issue with newer Virtualbox has been solved upstream for newer Plasma versions aswell. The identifier for their virtual graphics card has changed and it needed adaptation aswell for this in the code.
In the future on newer Plasma this should be no issue anymore.

1 Like

thanks for the help
I’m so newb w this stuff, apologies

I touched a few things, but it seems setting my desired X config using xrandr persists through reboot while using the Settings applet does not

not related per se, I note that the date had not updated automatically. I used Settings to toggle the “Set date and time automatically” switch. I am rewarded with an error message “Cannot set date” when I TURN OFF the automatic switch. some sort of weirdness there. leaves me skeptical of the KDE Settings applets, generally

I take it this thread remains closed. please let me know if I need to close it