back to Netrunner | back to Blue Systems

Hdmi with thinkpad T520[solved]

Hi,

i need to use hdmi with my thinkpad t520. But as far as i know is the hdmi-socket fix connected with the nvidia-graphic.
And i 'm using the intel graphic controller.

How can I activate the nividia-graphic?

netrunner 20.01
kernel 5.8.0-0.bpo.2-amd64

lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
        Subsystem: Lenovo 2nd Generation Core Processor Family Integrated Graphics Controller
        Kernel driver in use: i915

01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev a1)
        Subsystem: Lenovo GF119M [Quadro NVS 4200M]
        Kernel modules: nvidia

Thanks in advance!

Dieter

For this you need to install bumblebee

sudo apt install bumblebee-nvidia nvidia-driver-libs-nonglvnd nvidia-driver bumblebee primus

After that reboot and it should use the nvidia card.

thx for your reply, but, nowadays nothing is easy

sudo apt install bumblebee-nvidia nvidia-driver-libs-nonglvnd nvidia-driver bumblebee primus
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
bumblebee ist schon die neueste Version (3.2.1-20).
primus ist schon die neueste Version (0~20150328-7).
bumblebee-nvidia ist schon die neueste Version (3.2.1-20).
nvidia-driver ist schon die neueste Version (418.152.00-1).
nvidia-driver-libs-nonglvnd ist schon die neueste Version (418.152.00-1).
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libegl-mesa0:i386 libegl1:i386 libgbm1:i386 libopengl0 libopengl0:i386 libwayland-server0:i386 libxcb-xfixes0:i386 nvidia-egl-common nvidia-legacy-390xx-egl-icd
  nvidia-legacy-390xx-egl-icd:i386
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
8 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] 
nvidia-kernel-dkms (418.152.00-1) wird eingerichtet ...
Removing old nvidia-current-418.152.00 DKMS files...

------------------------------
Deleting module version: 418.152.00
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-418.152.00 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/418.152.00/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes nvidia-kernel-dkms (--configure):
 »installiertes nvidia-kernel-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
bbswitch-dkms (0.8-8) wird eingerichtet ...
Removing old bbswitch-0.8 DKMS files...

------------------------------
Deleting module version: 0.8
completely from the DKMS tree.
------------------------------
Done.
Loading new bbswitch-0.8 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/bbswitch/0.8/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes bbswitch-dkms (--configure):
 »installiertes bbswitch-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
nvidia-legacy-390xx-kernel-dkms (390.138-1~deb10u1) wird eingerichtet ...
Removing old nvidia-legacy-390xx-390.138 DKMS files...

------------------------------
Deleting module version: 390.138
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-390xx-390.138 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-legacy-390xx/390.138/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-kernel-dkms (--configure):
 »installiertes nvidia-legacy-390xx-kernel-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nvidia-driver:
 nvidia-driver hängt ab von nvidia-kernel-dkms (= 418.152.00-1) | nvidia-kernel-418.152.00; aber:
  Paket nvidia-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-kernel-418.152.00 ist nicht installiert.
  Paket nvidia-kernel-dkms, das nvidia-kernel-418.152.00 bereitstellt, ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes nvidia-driver (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nvidia-legacy-390xx-driver:
 nvidia-legacy-390xx-driver hängt ab von nvidia-legacy-390xx-kernel-dkms (= 390.138-1~deb10u1) | nvidia-legacy-390xx-kernel-390.138; aber:
  Paket nvidia-legacy-390xx-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-kernel-390.138 ist nicht installiert.
  Paket nvidia-legacy-390xx-kernel-dkms, das nvidia-legacy-390xx-kernel-390.138 bereitstellt, ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-driver (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von bumblebee:
 bumblebee hängt ab von bbswitch-dkms | bbswitch-source; aber:
  Paket bbswitch-dkms ist noch nicht konfiguriert.
  Paket bbswitch-source ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes bumblebee (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von bumblebee-nvidia:
 bumblebee-nvidia hängt ab von bumblebee (= 3.2.1-20); aber:
  Paket bumblebee ist noch nicht konfiguriert.
 bumblebee-nvidia hängt ab von nvidia-driver | nvidia-legacy-390xx-driver | nvidia-legacy-340xx-driver | nvidia-legacy-304xx-driver | nvidia-kernel-dkms | nvidia-legacy-390xx-kernel-dkms | nvidia-legacy-340xx-kernel-dkms | nvidia-legacy-304xx-kernel-dkms | nvidia | nvidia-current | nvidia-current-updates | nvidia-driver-binary | nvidia-304 | nvidia-304-updates | nvidia-experimental-304 | nvidia-310 | nvidia-310-updates | nvidia-experimental-310 | nvidia-313 | nvidia-313-updates | nvidia-experimental-313 | nvidia-319 | nvidia-319-updates | nvidia-experimental-319 | nvidia-325 | nvidia-325-updates | nvidia-experimental-325 | nvidia-331 | nvidia-331-updates | nvidia-experimental-331 | nvidia-334 | nvidia-334-updates | nvidia-experimental-334 | nvidia-337 | nvidia-337-updates | nvidia-experimental-337 | nvidia-340 | nvidia-340-updates | nvidia-experimental-340 | nvidia-343 | nvidia-343-updates | nvidia-experimental-343 | nvidia-346 | nvidia-346-updates | nvidia-experimental-346 | nvidia-349 | nvidia-349-updates | nvidia-experimental-349 | nvidia-352 | nvidia-352-updates | nvidia-experimental-352 | nvidia-355 | nvidia-355-updates | nvidia-experimental-355 | nvidia-358 | nvidia-358-updates | nvidia-experimental-358 | nvidia-361 | nvidia-361-updates | nvidia-experimental-361 | nvidia-364 | nvidia-364-updates | nvidia-experimental-364 | nvidia-367 | nvidia-367-updates | nvidia-experimental-367 | nvidia-375 | nvidia-375-updates | nvidia-experimental-375 | nvidia-378 | nvidia-378-updates | nvidia-experimental-378 | nvidia-381 | nvidia-381-updates | nvidia-experimental-381 | nvidia-384 | nvidia-384-updates | nvidia-experimental-384 | nvidia-387 | nvidia-387-updates | nvidia-experimental-387 | nvidia-driver-390 | nvidia-driver-410; aber:
  Paket nvidia-driver ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-driver ist noch nicht konfiguriert.
  Paket nvidia-legacy-340xx-driver ist nicht installiert.
  Paket nvidia-legacy-304xx-driver ist nicht installiert.
  Paket nvidia-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-340xx-kernel-dkms ist nicht installiert.
  Paket nvidia-legacy-304xx-kernel-dkms ist nicht installiert.
  Paket nvidia ist nicht installiert.
  Paket nvidia-current ist nicht installiert.
  Paket nvidia-current-updates ist nicht installiert.
  Paket nvidia-driver-binary ist nicht installiert.
  Paket nvidia-304 ist nicht installiert.
  Paket nvidia-304-updates ist nicht installiert.
  Paket nvidia-experimental-304 ist nicht installiert.
  Paket nvidia-310 ist nicht installiert.
  Paket nvidia-310-updates ist nicht installiert.
  Paket nvidia-experimental-310 ist nicht installiert.
  Paket nvidia-313 ist nicht installiert.
  Paket nvidia-313-updates ist nicht installiert.
  Paket nvidia-experimental-313 ist nicht installiert.
  Paket nvidia-319 ist nicht installiert.
  Paket nvidia-319-updates ist nicht installiert.
  Paket nvidia-experimental-319 ist nicht installiert.
  Paket nvidia-325 ist nicht installiert.
  Paket nvidia-325-updates ist nicht installiert.
  Paket nvidia-experimental-325 ist nicht installiert.
  Paket nvidia-331 ist nicht installiert.
  Paket nvidia-331-updates ist nicht installiert.
  Paket nvidia-experimental-331 ist nicht installiert.
  Paket nvidia-334 ist nicht installiert.
  Paket nvidia-334-updates ist nicht installiert.
  Paket nvidia-experimental-334 ist nicht installiert.
  Paket nvidia-337 ist nicht installiert.
  Paket nvidia-337-updates ist nicht installiert.
  Paket nvidia-experimental-337 ist nicht installiert.
  Paket nvidia-340 ist nicht installiert.
  Paket nvidia-340-updates ist nicht installiert.
  Paket nvidia-experimental-340 ist nicht installiert.
  Paket nvidia-343 ist nicht installiert.
  Paket nvidia-343-updates ist nicht installiert.
  Paket nvidia-experimental-343 ist nicht installiert.
  Paket nvidia-346 ist nicht installiert.
  Paket nvidia-346-updates ist nicht installiert.
  Paket nvidia-experimental-346 ist nicht installiert.
  Paket nvidia-349 ist nicht installiert.
  Paket nvidia-349-updates ist nicht installiert.
  Paket nvidia-experimental-349 ist nicht installiert.
  Paket nvidia-352 ist nicht installiert.
  Paket nvidia-352-updates ist nicht installiert.
  Paket nvidia-experimental-352 ist nicht installiert.
  Paket nvidia-355 ist nicht installiert.
  Paket nvidia-355-updates ist nicht installiert.
  Paket nvidia-experimental-355 ist nicht installiert.
  Paket nvidia-358 ist nicht installiert.
  Paket nvidia-358-updates ist nicht installiert.
  Paket nvidia-experimental-358 ist nicht installiert.
  Paket nvidia-361 ist nicht installiert.
  Paket nvidia-361-updates ist nicht installiert.
  Paket nvidia-experimental-361 ist nicht installiert.
  Paket nvidia-364 ist nicht installiert.
  Paket nvidia-364-updates ist nicht installiert.
  Paket nvidia-experimental-364 ist nicht installiert.
  Paket nvidia-367 ist nicht installiert.
  Paket nvidia-367-updates ist nicht installiert.
  Paket nvidia-experimental-367 ist nicht installiert.
  Paket nvidia-375 ist nicht installiert.
  Paket nvidia-375-updates ist nicht installiert.
  Paket nvidia-experimental-375 ist nicht installiert.
  Paket nvidia-378 ist nicht installiert.
  Paket nvidia-378-updates ist nicht installiert.
  Paket nvidia-experimental-378 ist nicht installiert.
  Paket nvidia-381 ist nicht installiert.
  Paket nvidia-381-updates ist nicht installiert.
  Paket nvidia-experimental-381 ist nicht installiert.
  Paket nvidia-384 ist nicht installiert.
  Paket nvidia-384-updates ist nicht installiert.
  Paket nvidia-experimental-384 ist nicht installiert.
  Paket nvidia-387 ist nicht installiert.
  Paket nvidia-387-updates ist nicht installiert.
  Paket nvidia-experimental-387 ist nicht installiert.
  Paket nvidia-driver-390 ist nicht installiert.
  Paket nvidia-driver-410 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes bumblebee-nvidia (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von primus:
 primus hängt ab von bumblebee; aber:
  Paket bumblebee ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes primus (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 nvidia-kernel-dkms
 bbswitch-dkms
 nvidia-legacy-390xx-kernel-dkms
 nvidia-driver
 nvidia-legacy-390xx-driver
 bumblebee
 bumblebee-nvidia
 primus
E: Sub-process /usr/bin/dpkg returned an error code (1)

What have i to do to solve this problem?

Ciao!

Dieter

Try installing this from the buster-backports version as otherwise it will not be compatible with the newer kernel as the nvidia driver for this is proprietary and only compatible with one kernel generation.

So try
sudo apt install -t buster-backports bumblebee-nvidia nvidia-driver bumblebee primus
hopefully works

Again Thank you.

I tried it and got the following message:

Trigger fĂĽr libc-bin (2.28-10) werden verarbeitet ...
Trigger fĂĽr initramfs-tools (0.133+deb10u1) werden verarbeitet ...
update-initramfs: Generating /boot/initrd.img-5.8.0-0.bpo.2-amd64
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries 
    nor crypto modules. If that's on purpose, you may want to uninstall the 
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs 
    integration and avoid this warning.
I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=83dc6786-5520-4bff-a0ea-2bc579aeaa71)
I: Set the RESUME variable to override this.
Trigger fĂĽr update-glx (1.2.0~bpo10+1) werden verarbeitet ...
Trigger fĂĽr glx-alternative-nvidia (1.2.0~bpo10+1) werden verarbeitet ...
update-alternatives: Warnung: Neuinstallation der Alternative /usr/lib/nvidia ist erzwungen, weil Linkgruppe glx defekt ist
update-alternatives: /usr/lib/nvidia/bumblebee wird verwendet, um /usr/lib/glx (glx) im automatischen Modus bereitzustellen
Trigger fĂĽr glx-alternative-mesa (1.2.0~bpo10+1) werden verarbeitet ...
Trigger fĂĽr libc-bin (2.28-10) werden verarbeitet ...
Trigger fĂĽr initramfs-tools (0.133+deb10u1) werden verarbeitet ...
update-initramfs: Generating /boot/initrd.img-5.8.0-0.bpo.2-amd64
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries 
    nor crypto modules. If that's on purpose, you may want to uninstall the 
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs 
    integration and avoid this warning.
I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=83dc6786-5520-4bff-a0ea-2bc579aeaa71)
I: Set the RESUME variable to override this.
Trigger fĂĽr bumblebee (3.2.1-26~bpo10+1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 bbswitch-dkms
 nvidia-legacy-390xx-kernel-dkms
 nvidia-legacy-390xx-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

and a second try:

0 aktualisiert, 0 neu installiert, 0 zu entfernen und 186 nicht aktualisiert.
3 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] 
bbswitch-dkms (0.8-8) wird eingerichtet ...
Removing old bbswitch-0.8 DKMS files...

------------------------------
Deleting module version: 0.8
completely from the DKMS tree.
------------------------------
Done.
Loading new bbswitch-0.8 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/bbswitch/0.8/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes bbswitch-dkms (--configure):
 »installiertes bbswitch-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
nvidia-legacy-390xx-kernel-dkms (390.138-1~deb10u1) wird eingerichtet ...
Removing old nvidia-legacy-390xx-390.138 DKMS files...

------------------------------
Deleting module version: 390.138
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-390xx-390.138 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-legacy-390xx/390.138/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-kernel-dkms (--configure):
 »installiertes nvidia-legacy-390xx-kernel-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nvidia-legacy-390xx-driver:
 nvidia-legacy-390xx-driver hängt ab von nvidia-legacy-390xx-kernel-dkms (= 390.138-1~deb10u1) | nvidia-legacy-390xx-kernel-390.138; aber:
  Paket nvidia-legacy-390xx-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-kernel-390.138 ist nicht installiert.
  Paket nvidia-legacy-390xx-kernel-dkms, das nvidia-legacy-390xx-kernel-390.138 bereitstellt, ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-driver (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 bbswitch-dkms
 nvidia-legacy-390xx-kernel-dkms
 nvidia-legacy-390xx-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

And now?

Dieter

Bei fehlerhaften Paketen/Abhängigkeiten hilft oft diese Eingabe auf der Kommandozeile:

sudo apt-get --fix-broken install

ok, I tried it. The result is

pfiff@dieter-pc:~$ sudo apt-get --fix-broken install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
3 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
bbswitch-dkms (0.8-8) wird eingerichtet ...
Removing old bbswitch-0.8 DKMS files...

------------------------------
Deleting module version: 0.8
completely from the DKMS tree.
------------------------------
Done.
Loading new bbswitch-0.8 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/bbswitch/0.8/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes bbswitch-dkms (--configure):
 »installiertes bbswitch-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
nvidia-legacy-390xx-kernel-dkms (390.138-1~deb10u1) wird eingerichtet ...
Removing old nvidia-legacy-390xx-390.138 DKMS files...

------------------------------
Deleting module version: 390.138
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-390xx-390.138 DKMS files...
Building for 5.8.0-0.bpo.2-amd64
Building initial module for 5.8.0-0.bpo.2-amd64
Error! Bad return status for module build on kernel: 5.8.0-0.bpo.2-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-legacy-390xx/390.138/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-kernel-dkms (--configure):
 »installiertes nvidia-legacy-390xx-kernel-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nvidia-legacy-390xx-driver:
 nvidia-legacy-390xx-driver hängt ab von nvidia-legacy-390xx-kernel-dkms (= 390.138-1~deb10u1) | nvidia-legacy-390xx-kernel-390.138; aber:
  Paket nvidia-legacy-390xx-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-kernel-390.138 ist nicht installiert.
  Paket nvidia-legacy-390xx-kernel-dkms, das nvidia-legacy-390xx-kernel-390.138 bereitstellt, ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-driver (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 bbswitch-dkms
 nvidia-legacy-390xx-kernel-dkms
 nvidia-legacy-390xx-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

and now?

Ciao!

Dieter

I´m a bit irritated about Kernel 5.8.0-0, my system is up to date and still 20.01, kernel 5.7.0-0
Would you please show

inxi -Fz

Thanks for the reply

I have this kernel because this posting

https://support.blue-systems.com/t/problems-with-wlan-and-bluetooth/5072/6?u=pfiff

But nevertheless here is the result of “inxi -Fz”

inxi -Fz
System:    Host: dieter-pc Kernel: 5.8.0-0.bpo.2-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.14.5 
           Distro: Netrunner 20.01 (Twenty) 
Machine:   Type: Laptop System: LENOVO product: 4243FS9 v: ThinkPad T520 serial: <filter> 
           Mobo: LENOVO model: 4243FS9 serial: <filter> UEFI [Legacy]: LENOVO v: 8AET64WW (1.44 ) date: 07/26/2013 
Battery:   ID-1: BAT0 charge: 38.6 Wh condition: 38.6/47.5 Wh (81%) 
CPU:       Topology: Quad Core model: Intel Core i7-2670QM bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 882 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 901 2: 996 3: 1097 4: 1054 5: 1016 6: 880 7: 857 8: 947 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GF119M [Quadro NVS 4200M] driver: N/A 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa tty: N/A 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.3.6 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
           Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.8.0-0.bpo.2-amd64 
Network:   Device-1: Intel 82579LM Gigabit Network driver: e1000e 
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce 
           IF: wlp3s0 state: up mac: <filter> 
           IF-ID-1: wwp0s29u1u4i6 state: down mac: <filter> 
Drives:    Local Storage: total: 1.36 TiB used: 298.81 GiB (21.4%) 
           ID-1: /dev/sda vendor: Hitachi model: HTS727550A9E364 size: 465.76 GiB 
           ID-2: /dev/sdb type: USB vendor: Toshiba model: External USB 3.0 size: 931.51 GiB 
Partition: ID-1: / size: 38.03 GiB used: 12.07 GiB (31.7%) fs: ext4 dev: /dev/sda8 
           ID-2: /home size: 111.94 GiB used: 87.97 GiB (78.6%) fs: ext4 dev: /dev/sda6 
           ID-3: swap-1 size: 1.65 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2636 
Info:      Processes: 274 Uptime: 4m Memory: 7.66 GiB used: 1.61 GiB (21.0%) Shell: bash inxi: 3.0.32 

And now?

Ciao!

Dieter

Sadly it seems to me that the legacy nvidia driver is not compatible with the newer 5.8 kernel. So from the changelog it should be compatible with the 5.6 kernel but probably nothing newer.
As backports earliest kernel is 5.8 (and 5.9 is in there aswell already) I don’t think there is an easy solution for this.

Of course you could manually download an older kernel from https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6.19/
You need:
linux-headers … _amd64
linux-headers … _all
linux-image-unsigned-generic
linux-modules-generic

If you have all of those deb packages in a folder open a terminal in the folder and install them in one go
sudo dpkg -i *.deb
After that you can reboot into 5.6 kernel (hopefully the fix for your wifi is still working with this one)
Be aware: Choose the 5.6 kernel in the boot menu as it otherwise will boot into the newest kernel automatically.
If the older kernel works with your bumblebee nvidia & wifi you can of course remove the newer 5.8 kernel.

I’m going to become crazy.

I changed, as suggested, to kernel 5.6.19

installed again

`sudo apt install -t buster-backports bumblebee-nvidia nvidia-driver bumblebee primus`

rebooted

and then I get the following

lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
        Subsystem: Lenovo 2nd Generation Core Processor Family Integrated Graphics Controller
        Kernel driver in use: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev ff)
        Kernel modules: nvidia
01:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev ff)

and

 nvidia-settings 

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

And now?

Just for fun (?) I tried the live version of OS Neptune 6.5. And there, without any changes from me, the nouveau driver (at least) has been working.
And, as far as I know, the nouveau driver is supporting hdmi. Should I change the OS?

Ciao!

Dieter

1 Like

If the official sources don´t work, why not trying a ppa?
F.i.: ppa:graphics-drivers/ppa

It is a real nice experience to find out that Neptune 6.5. handles your problem out of the box.
leszek will be glad to hear that!

Ok, I added the ppa, then update and dist-upgrade, no improvement. Then I purged everything what looks like belonging to this nvidia-Sh**, after the purge-Orgy, I installed the nvidia-legacy-390xx-driver again.
The result is the same

------------------------------
Deleting module version: 390.138
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-390xx-390.138 DKMS files...
Building for 5.6.19-050619-generic 5.8.0-0.bpo.2-amd64
Building initial module for 5.6.19-050619-generic
Error! Bad return status for module build on kernel: 5.6.19-050619-generic (x86_64)
Consult /var/lib/dkms/nvidia-legacy-390xx/390.138/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-kernel-dkms (--configure):
 »installiertes nvidia-legacy-390xx-kernel-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nvidia-legacy-390xx-driver:
 nvidia-legacy-390xx-driver hängt ab von nvidia-legacy-390xx-kernel-dkms (= 390.138-1~deb10u1) | nvidia-legacy-390xx-kernel-390.138; aber:
  Paket nvidia-legacy-390xx-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-kernel-390.138 ist nicht installiert.
  Paket nvidia-legacy-390xx-kernel-dkms, das nvidia-legacy-390xx-kernel-390.138 bereitstellt, ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-driver (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 nvidia-legacy-390xx-kernel-dkms
 nvidia-legacy-390xx-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

It’s like living in the Middle Ages. But we have the year 2020 and I have no hdmi???

Ciao!

Dieter

Seems to be problems with the NVIDIA Corporation GF119M already since 2016.
[https://ubuntuforums.org/showthread.php?t=2344286]
When testing with Neptune 6.5: Did you check the system constellation?
Drivers, kernel and settings? Just to compare the standings to netrunner.
Perhaps you could take some ideas out of that.

So it fails compiling for the 5.6 kernel aswell. That is really weird as the official changelog of the nvidia driver says it should build fine for 5.6 as it comes with patches.
That is really unfortunate.

But if it is running with nouveau on Neptune then it should work on Netrunner aswell. So my suggestion is removing all the nvidia proprietary driver stuff and try only setting up stuff with nouveau instead the same way you do it with Neptune.

Solved.

I did what leszek told me. Removing all nvidia driver stuff and then installed the nouveau stuff. Now both graphics are active

Ciao!

Dieter

Great that it worked.

Have fun :slight_smile: