HI! BCM4352 help please

running 2014.04 , with BCM4352 not detected.

Found these but I dont understand PKGBUILD, AUR, DKMS, and so on. I’m also getitng lost following all the interrelated links

See, I have tried.

PLEASE can some provide a link to STEP by STEP instructions in a single page/post.

I will learn as I go but its impossible at the moment and more difficult than it needs to be - most distros auto detect the card but then , this is arch based (!)

** EDIT:
got this far…

[daz@VAIO broadcom-wl]$ makepkg
error: package ‘linux’ was not found
cat: /usr/lib/modules/extramodules–ARCH/version: No such file or directory
==> Making package: broadcom-wl (Wed 7 May 22:57:55 BST 2014)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Found hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz
-> Found modprobe.d
-> Found license.patch
-> Found linux-recent.patch
-> Found gcc.patch
==> Validating source files with sha1sums…
hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz … Passed
modprobe.d … Passed
license.patch … Passed
linux-recent.patch … Passed
gcc.patch … Passed
==> Extracting sources…
-> Extracting hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz with bsdtar
==> Starting prepare()…
patching file src/wl/sys/wl_linux.c
patching file src/wl/sys/wl_linux.c
patching file Makefile
==> Removing existing pkg/ directory…
==> Starting build()…
make: *** /usr/lib/modules//build: No such file or directory. Stop.
==> ERROR: A failure occurred in build().
[daz@VAIO broadcom-wl]$ uname -a
Linux VAIO 3.10.34-1-MANJARO #1 SMP Tue Mar 25 02:44:36 UTC 2014 x86_64 GNU/Linux

** EDIT 2:
installed the "linux"package and selected a 3.10 kernel option, the others were 3.11 , 3.12, and 3.4

tried again now all seemed to work BUT

when I restarted and selected netrunner at the grub prompt a few lines of text appears and I noticed some text in red saying something like [FAILED] unable to load kernel dkms check servicectrl … then more text flashes up the screen too fast. then a black screen appears with flashing “(tty1) Login:” but I cant type anything.

GREAT! Locked out.

Might go back to ubuntu !


no-one at all can answer this with a proven fix?

golly- not much of a support forum compelling enough to warrant people sticking with “your” product?

I would recommend using octopi for this. There you have a YAOURT Entry that you can choose on the right which allows you to search and install packages from the AUR directly. I would try installing the necessary driver with it.

edit: The delayed answer might be because you posted in the wrong forum. I moved this thread to the Netrunner Rolling subforum.

Ah. Opops. Thank you and sorry. I will try this proposal.

Allready in the repo, no need to rebuild:
sudo pacman -S linux310-broadcom-wl
or install through octopi.

The example above is for the linux 3.10 kernel, this will need to be changed to whatever kernel you are running, to find out type in: uname -r .

I’ve moved to the KDE version of netrunner. No time for this. I’ve got over the need to tweak … It should just work. Thanks anyway… netrunner KDE working a charm

Umm, Both editions are KDE based, do you mean Netrunner Standard?

On my laptop with a bcm4313 (which are still widely used even in most newer laptops) the wl drivers cause my system to have NO Wifi, I have to use the b43 driver included with the kernel and the b43 firmware included in the manjaro-firmware package, so installing the wl proprietary driver by default at this point would cause problems for more people than they would help, this is however easily added with the manjaro system settings hardware drivers app, or by using sudo pacman -S linux310-broadcom-wl in the terminal, both option are very easy and safe.

you need to install the correct driver for the chipset. You obviously have a diffrerent chipset. From memory the broadcom driver supports around 8 chipsets. Like i said, this is BASIC stuff and should work out of the box irrespective of what distro this is based on. Windows7 supports the chip. Until Arch/Manjaro become “out of the box” - FULLY - experiences (like Mint/Ubuntu) then it will always be a 2nd rate distro for geeks and hackers to piss around with day after day.
Me - I just want a working O/S - I have enough problems with configuring complex apps for my digital photography hobby - and I’m not one for pissing about with an O/S just to get it to a level where it should have been before it was released.
I’ve moved to kubuntu - like I said - works a charm
Nuff said

It depends on the target audience. I wouldn not talk about 2nd or 1st rate distros as it strongly depends on your needs and the target audience a distro is adressing. So this is just wrong.

Netrunner Rollings target audience are experienced users and not total newbies or linux beginners.
Hardware drivers are a pool of problems of its own independant from OS used they always cause headaches.

For this particular problem we need to find a solution to load the correct driver for the chipset however as there are no licensing problems preventing that.

OK, on my laptop everything loads and runs even Wifi out of the box, it has been that way for several laptops that I have installed Manjaro on. NOW, Ubuntu. kubuntu, etc. half of the time no wifi, need to hook up a wired connection and install the drivers needed, yea, that’s noob friendly.

The Manjaro developers simply chose to include the drivers that work with the most number of broadcom chips as default, the fact the the WL drivers are precompiled for your kernel in their repository for you to install say a lot for the Manjaro devs concern for compatibility.

Here is a chart on wifi chips and linux support for you to look at: