How do I restart plasma-nm?

Ever since KDE switched to plasma-nm, I’ve had nothing but problems. I abandoned another distro using KDE because of it. Now I’m having the same issues in Netrunner-OS. Among the symptoms, WIFI is arbitrarily dropped. WIFI connectivity issues locks up the plasma desktop, forcing reboots. WIFI forgets passwords. Connecting to other hotspots can cause NM to lock up and the panel with it. Etc… This isn’t isolated to one system, but to all my systems. Clearly it’s a problem with KDE.

The only solution I’ve come up with is to either switch back to the old network manager (which hasn’t worked in other distros) or to try to reboot plasma-nm. I could also try Gnome Shell or Unity, but really don’t want to. Can anyone offer me an all-in-one command-line command for stopping and restarting plasma-nm?

Okay. That got me nowhere.

plasma-nm, in my experience, is as close to a complete disaster as wifi management can get. I already dropped another KDE distro because it was single-handedly locking up plasma-desktop on an Acer. Now it’s doing the same thing on my System76 laptop. Evey 15 minutes or so it looses the connection, slows down, or locks up the panel. I have to restart plasma-desktop, kill the wifi connection, then restart it. This is a PITA.

But, I swear, this isn’t a rant. Just reporting the facts.

Is there a way to replace plasma-nm with Gnome network management? I’ve never had a problem with gnome’s wifi.

Edit: Found this guide:

Gonna’ try it even though it’s a bit outdated.
Done. Removed plasma-nm.

Gnome’s (network-manager-gnome) nm-applet is working beautifully so far. WIll update with longterm results.

I know that under Netrunner Rolling you can remove plasma-nm (kdeplasma-applets-plasma-nm) and install the older KNetworkManager (kdeplasma-applets-networkmanagement) from the AUR. I wonder if something similar is also possible under Netrunner 14?

I know it’s possible because that’s what I did with a Debian based distro of KDE. The plasma desktop problems, unfortunately, didn’t go away (this was with a rolling release however). It’s my opinion that KDEs network management is very poorly coded.

KDE5 will not, however, allow you to switch back to KNetworkManager. I assume, but don’t know, that Gnome’s nm-applet would still work on KDE5? If not, I won’t be switching to KDE5 until the whole issue is solved (which, based on KDE4, might be never). I don’t get KDE. I’ve tried filing bug reports, but I’ve never been able to successfully create an account with their bug management system – too much security fiddle-faddle.
So far, it’s night and day. My connection hasn’t been dropped once. It hasn’t slowed down. Plasma-desktop hasn’t frozen. There’s been no need to restart it, log out or reboot. No network issues with suspend and resume.

I’m going to replace nm-plasma on all my systems (all presently running Frontier). In truth, I think Netrunner should consider using Gnome’s applet by default – (or Netrunner can continue playing Russian Roulette). I know nm-applet works on some systems, but it’s a mess on all of mine – System76, Acer One, and an old 32bit HP laptop. Are KDE devs living in a bubble? Or do they just not care? I don’t get it… but I’m happy. The problem seems to be solved.

I think we should deliver whats best for the user and so far we did not have such a report about plasma networkmanagement applet.
I honestly think we should encourage and help on solving issues with it.
The Developers itself live in a kind of bubble like everyone else. The bubble is defined by the hardware you run and test your software. So they as all software developers are dependant on feedback from other users.
And me as a developer I can tell you how much it bugs me that there is a bug in a piece of software I wrote. I guess the devs of plasma networkmanagement also have the same feeling about that.

If the initial problem is really solved can you add a [solved] in the title of your initial post.