How to remove Plymouth?

I am trying to remove Plymouth from my system in order to speed up booting. I have followed the directions in


However, I cannot remove plymouth package, because it is required by netrunnerarch-default-settings. Also, even though I have disabled plymouth in systemctl, it still shows up in boot-up messages.

Is there a netrunner-specific process to remove plymouth?

Nope, you would use the same method as Arch.

To remove a package, which is required by another package, without removing the dependent package:

sudo pacman -Rdd plymouth

Alright, but what puzzles me is that Plymouth appears in the boot-up messages, even though it is disabled:

$ systemctl is-enabled kdm-plymouth
> disabled

I was trying to do exactly that just the other week, but gave up on it because of the netrunner dependency thing and didn’t want to waste too much time on it.

It feels like it is not needed and when doing a systemd-analyze plot > plot.svg it shows plymouth really takes some time to start and in the end it does not seem it is needed.

However, since it is needed by the netrunnerarch-default-settings, removing it, even without removing netrunnerarch-default-settings would that not break the system?


I’m not sure your having a KDM / plymouth issue since 2014.09 used SDDM by default but.
You can use these commands to remove that particular issue:

sudo systemctl stop kdm-plymouth.service
sudo systemctl disable kdm-plymouth.service
sudo systemctl start kdm.service
sudo systemctl enable kdm.service

If you wish to use SDDM instead, replace the last two commands above with these:

sudo systemctl start sddm.service
sudo systemctl enable sddm.service

@ Platon91,
No that’s not a hard dependency, I believe it is only there to ensure that the Netrunner theme package would be installed by default.
Using the command I gave earlier is perfectly safe.

Well, went through it and seems to work ok, no system crash.

There were some funny graphical glitches though, realized I needed to rebuilt the initramfs image with mkinitcpio after removing the plymouth hook from the /etc/mkinitcpio.conf file. Now no graphical glitches. Thanks for the help…