Back to Netrunner | Back to Blue Systems

How to set network(cifs) share option cache=loose?

Hi,

I’m new user of netrunner os, so far I love it. But I’m having problems with clementine and other players buffering songs from network share I set up via Network icon. Found somewhere that buffering happens due to cache=strict option being set by default on new kernel. I could add specific fstab entry with cache=loose but this kind of denies purpose of KDE mounting. May be I can change default options for the whole mount.cifs module or something. Could someone give me a hint, how did you solve this.

I’m just learning linux basics.

This is not possible. The only configuration file for setting this is the /etc/fstab.
You could however also create a script to manually mount the cifs network if you wish where you can also set the mount parameter for the mount.cifs command.

Thanks for reply, not possible is better than not sure. I’m now looking into setting this up with autofs, reason I wanted this in KDE was that share is not always available.

Normally upstart should take care of this. But I am not sure (I know systemd can take care of it by its own. So a normal /etc/fstab entry is enough)

I’ve set up autofs, not much harder than adding fstab entry. One thing - I should say sorry to ubuntu based release guys, I’m actually using Manjaro based rolling release, so there’s bound to be differences. I did not notice those versions have different forums here (facepalm), I must go check my eyesight or something.