I love Netrunner but it wont install on modern UEFI Secure Boot Laptops

I am very impressed with Netrunner 14. In my humble and limited opinion it is one of the best laid out KDE distros I’ve seen to date. I am confused on this point my understanding is that Netrunner 14 is based on Ubuntu or Kubuntu. I mention this only because I installed Kubuntu on my HP 17 inch Touch Screen and on my Samsung ATIV8 both of which are UEFI Secure boot laptops. Both Ubuntu & Kubuntu installed on both laptops with out any issues regarding Secure Boot or being on Gparted UEFI system. Sadly I could not get Netrunner 14 to run on either system I say running because it did install on both systems but when restarted I got a Grub boot error on both systems . My point of confusion is why is it since Netrunner 14 is based on Kubuntu and Ubuntu why won’t it install properly on a UEFI Secureboot system laptop when Ubuntu and Kubuntu both install and run fine ? I did manage to install Netrunner on my old HP HDX laptop without any issues and love it but my HP HDX is a traditional bios based system and not a modern UEFI Secureboot system . I would sincerely appreciate any help and insights in over coming this problem . I would like to suggest that perhaps the Netrunner team consider using UEFI Secureboot system Ubuntu and Kubuntu both use to aviod this issue. Thanks in advance to the community for your help and insights into this problem. Kindest regards.

Are you sure you downloaded the Standard edition and not the Rolling? The Rolling Edition is based off of Manjaro/arch and not Kubuntu/Debian Standard Edition.

Thank you for responce. Yes I am sure I downloaded Netrunner 14 the release candiate based on Ubuntu & Kubuntu.

Great, I’m glad it was not just a mishap with the download.

I had similar problem when I bought my HP700 which came with Windows 8. I was able to disable that by going into bios and change the settings after doing a Google search as how to do it. I haven’t had much luck with the Rolling release, but I’m very impressed the 14 Netrunner, and that’s what I’m going to be using for all my computers. It has been absolutely running flawless, and that testing the RC version. I can’t wait until the actual version is released. Hope this helps.


Thank you so much for taking the time to respond to my post. But could you kindly tell me if yoiu experienced problems such as grub menu not installing correctly ? perhaps a informative link that help solved your issue of installing Netrunner 14 on your HP-700 would be greatly appreciated. Kindest regards.



My problem with HP700 was that I coudn’t even make it to boot from the DVD. Then I saw the tutorial on Nerunner’s website that I had to disable the secure boot.

On my computer, I pressed F10 for the boot option, in order to acces the bios.
Then You have UEFI Boot Source & Legacy Boot Source, which you can only enable one of them. When you enable one, the other one is disabled.
Here are the steps I took to boot from the DVD:
To boot from DVD to run Netrunner enable Legacy Boot Source

Legacy Boot Source

Reboot and hit ESC
Then next line below is SATA2
hit SATA2 to boot from DVD

This is how I got it to install from the DVD. Hope this helps.


You’ll need to disable secure boot:

I have the same problem. The problem is not the secure boot. Just cannot boot from dvd becauce it is incompatible with UEFI. I hope this will be fixed in the stable version.
(sorry for my English)


If your able to get UEFI to boot from the DVD drive then the first ting I would check is if your ISO might have been corrupt, if that is good then the second thing I would try is using a USB key instead of a DVD.

Also have you tried re-setting your bios back to factory defaults? I’ve seen this help others in the past that had issues.

Hopefully the issue of Netrunner not being able to install correctly on a UEFI Secure Boot systems will be resolved in the stable release. It should be noted that Netrunner is based on Kubuntu 14.04 which has no problems installing installing on any of my UEFI & Secure Boot systems at all. Hopefully the Netrunner developers will just simply use Kubuntu all ready UEFI and Secure Boot loader as is for a trouble free install on systems that require UEFI and Secure Boot status to remain active . Kindest regards .

Honestly speaking. We did not change anything about the uefi secureboot stuff kubuntu ships with. So in theory it should also work on the current rc.
The fact it isn’t working is confusing for us developers aswell. The recommendation will stay disable secure boot. It brings near to nothing benefical anyways to have this enabled.

I am in the same situation:

HP Pavillion TS 11 Notebook PC

I can get it installed but when it boots, its goes straight to this: grub~ and no further does not give the option of netrunner to boot into

Mark: Is SecureBoot OFF?

yes secure boot is turned off. can install ok but goes straight to the grub prompt after installation has been done an computer is re started