back to Netrunner | back to Blue Systems

I would like to login as root (no, I don't want to use sudo)

I know what I am doing. I am not afraid to crash my system, there are no chances that that can happen.
I know that many things can be done with the sudo su command.
What I cannot do with that command is to start Kate from the Dolphin file manager to edit a file owned by root… to do that I need to login, when Netrunner starts, as root.
I have already enabled the root password with the command sudo passwd root which was accepted.
What is still missing is the possibility to specify, at login time, a user (root in this case) different from the standard user generated at installation time.

I tried to search all of the file system for a configuration file containing the row :
AllowRoot=false
to change it to true, but the search did not give any result.

Can please somebody tell me how to do what I need ? Thanks.

Al
P.S. Running here Netrunner 17.03

kdesudo should be used to start kde graphical applications, not sudo.

An idea;
Make a copy of Kate in the “KDE Menu Editor” & name it. ie: Kate (Root). Then change the command line for Kate (Root) to; kdesudo kate. Save the settings for KDE Menu Editor" & exit the program.

[attachment=1041]

Now when you want to edit a root file, click “Open With” and select Kate (Root).

Although, it would be nice if Dolphin was more like this version in “Maui” Thread Post #2

Something to be aware of, even if it’s about another Linux flavor, results may be similar.

Please don’t use kdesudo kate.
This is depreciated soon anyways as kde devs block opening up kate with kdesudo or as root in general.
It should not be running as root.

See this blogpost: https://blog.martin-graesslin.com/blog/2017/02/editing-files-as-root/

The same will happen with dolphin btw.

So to edit a document and save it as root use

EDITOR=kate sudoedit /path/to/file
This will ensure that kate is not run as root but instead a copy of that file is saved temporary and Kate started as normal user. After closing the file sudoedit takes care of moving the file to the right location.

[font=Helvetica, Arial, sans-serif]Thank you for the info & a secure work-around.

[font=Helvetica, Arial, sans-serif]Rather than hindering root access to kate & other qt gui app/programs, X11, and possibly qt should be patched to prevent such hypothetical attacks. Until that happens… AWARENESS is key![/font][/font]

Thanks Winux200 and leszeq for your advice. I tried kdesudo and it works, but accepting the suggestion of leszeq will use the alternative and more secure way.

Another simple question : I have a good grasp of Windows and other Linux distributions, but I am new at netrunner… how can I in netrunner place an icon on the desktop ? What in Windows is called a shortcut… I tried the standard way to copy the icon shown in Dolphin, trying then to paste it as a shortcut on the desktop, but it doesn’t work… that works e.g. in Xubuntu, but not in netrunner…

TNX

Al

Usually you can drag and drop on the desktop and will ask if you want to move, copy or link to.

Thanks leszek. That’s exactly what I tried to do, but it didn’t work. My error was that, misled by Windows and Xubuntu, I tried to do it using the customary right mouse button… with Netrunner, you must use the left mouse button… with it, it works… but now I have to discover how you can move an icon on the desktop… once you have placed it somewhere, it stays there, no matter how you try to move it… but perhaps there surely must be something I have overlooked…

And, as far as I have seen, it doesn’t ask you what you want to do… it simply places a link on the Desktop to the file (in my case an executable)…

Al

If you use the default folderview desktop containment you should be able to move the icon.
It sounds to me that you don’t use that folderview containment.
(Right click -> settings -> Layout is where you can check)

Perhaps your Desktop Icons are Locked?

Right click the desktop, and from the pop-up menu window, select Icons > from there you’ll see the “Locked” option and other Icons settings.
From the same Desktop pop-up menu window you can also unlock Widgets, then you’ll be able to right click an app from the Application Menu and select “Add to Desktop” which is just another way to add a linked app to the desktop.

Left click & holding an App icon from Dolphin or Application Menu to drag & drop (used on Win-x OS also) allows you to link, copy, or move (move, from Dolphin) an App to the Desktop. Personally, I prefer to Link an App Icon, since the Copy has a trust warning when opened.

That was it ! After setting folderview as layout, now everything works as I expect it to work.
Thanks, and thanks also to Winux2000 for his advice. My icons weren’t locked, just my desktop layout wasn’t set to folderview. As that could have happened, I don’t know, but it is not much relevant now.

Al