Installation failed with 13.12, but I has been used 13.06 before?!

Please help, I keep get error while doing fresh installation:

Exception during installation:
Jan 27 08:28:32 netrunner / Traceback (most recent call last):
Jan 27 08:28:32 netrunner / File “/usr/share/ubiquity/”, line 1775, in
Jan 27 08:28:32 netrunner /
Jan 27 08:28:32 netrunner / File “/usr/share/ubiquity/”, line 78, in wrapper
Jan 27 08:28:32 netrunner / func(self)
Jan 27 08:28:32 netrunner / File “/usr/share/ubiquity/”, line 242, in run
Jan 27 08:28:32 netrunner / self.configure_bootloader()
Jan 27 08:28:32 netrunner / File “/usr/share/ubiquity/”, line 1031, in configure_bootloader
Jan 27 08:28:32 netrunner / “GrubInstaller failed with code %d” % ret)
Jan 27 08:28:32 netrunner / ubiquity.install_misc.InstallStepError: GrubInstaller failed with code 1

I attached the completed syslog …

It seems to me that kde-config-grub2 is causing this issue (in fact a package conflict which leads to the removal of grub2) . Can you test if removing the package kde-config-grub2 before starting the installation (on the live system) solves the problem for you ?

Thx, but how do I remove the package kde-config-grub2 on the live system?! Please help …

With muon or synaptic or the command line

sudo apt-get remove kde-config-grub2

Hi leszek, I removed “kde-config-grub2” on the live system before doing the fresh installation but still failed ?!
Attached the syslog again … Please help :frowning:

Still the same error

[quote]dpkg: dependency problems prevent removal of grub-pc:
Jan 27 17:17:14 netrunner grub-installer: kde-config-grub2 depends on grub-pc (>= 1.99~rc1-5) | grub-efi-amd64 | grub-efi-ia32; however:[/quote]

Is the package really removed ?

I have the same problem, same error message.

I have tried to install “grub-efi-amd64” on the live system before starting the installation. As dependency “grub-efi-amd64-bin” and “efibootmgr” have been installed and “grub-pc” have been removed. But the end of the installation was the same, same error message again.

On another partition I have Netrunner 13.06 installed. The “update-grub” commande on this system recognised the newly installed 13.12 and I was able to start it from the grub menu of 13.06.

The 13.12 system seems to be OK, but there is no grub-efi-amd64, only grub-pc is installed.