Installation Problems 64bit Rolling

I have tried the suggestions in the readme and still no luck with installation. I get to the “start Netrunner” click and some kind of endless script displays on the screen. I have tried the other manual options and have been able to get to “installed successfully” but it still hangs into an endless script over the Netrunner desktop on restart. I’ve tried USB, multiple bootable USB software, DVD, and even re-downloaded Netrunner 64 bit rolling again. Checksum is fine. I have tried every combo of enabled/disabled UEFI, Legacy, rapid start, quickboot, secureboot, et al. Same problems. Linux Mint 64 installed fine so hardware is functioning. Just Frustrated. It seems like my ideal OS, but no luck. Motherboard is Gigabyte H77N WIFI, it does have an UEFI bios so I’ve tried lots of combos since there is no “Disable UEFI” globally type option. Any ideas?

Is there an BIOS compatibility mode or sometimes called Legacy compatibility mode ?

No legacy mode, just options to treat HD, USB drives, etc. as “legacy”, which I’ve done and it still does not install. I am running a gigabyte GA-H77N motherboard with an UEFI Bios, a Xeon E3-1230v2 Ivy Bridge processor, Nvidia GTX 750 Ti and 8 gigs ram which is why I was excited to try the 64 bit rolling, that plus Arch base, KDE, seems ideal. Dream OS for a dream (relatively low power consumption) powerhouse of a PC in a tiny case.
If I install the manual “Manjaro” way is says everything installs “successful” but I still get the endless script loop (strings of numbers counting up) on top of the netrunner desktop logo…??? This is a clean install, and the only OS on system. Tried on a couple hard drives with no luck. I can at least be pretty sure it is not a hardware defect since I’ve run mint 16 and Windows 7 on it without issue. Any ideas?