Netrunner Home

Installation Rolling


#21

I just tried on my machine changing the blacklist r8169 to blacklist r8168 and rebooted my system.
The strange thing is, both of these drivers seem to work with my chipset.

On a gigabit connection it’s hard to guage the difference between these drivers.
However, I seem to be getting a better, more consistent throughput with the r8169 kernel module.
Not to mention, all of those acpi, etc. etc. msgs on boot are now gone.


#22

one grub.cfg kernel param that works like a charm is

[b]video=SVIDEO-1:d[/b]

but it helps the 6+ minutes booting time only on intel integrated HD graphics like

intel 965GM chip , makes the laptop fly !


#23

As an experiment I reinstalled Rolling with no Internet. It went straight forward and fast, no long wait on configuring. Then I tried removing the driver but got a lot of fail messages so I went with the above, commenting out blacklist r8169 inside the .conf file and rebooted. I could get online just fine after that but when I went into Discover it was only showing installed programs and there was a message “unable to lock database” and there were no updates available.

So I tried reinstalling with Internet and it took over 18m in the postinstall configuring stage. After repeating the above I got the same results. I also tried copying the .conf file onto the USB installation drive but it would not allow me.

There be bugs in the installer!


#24

Sounds Like it, I’ll pass that on to Philip at Manjaro.

The Live “installation” ISO uses overlayfs, aka compressed filesystem files that are overlapped in memory as it boots (root, mhwd, desktop, then live). The installer uncompresses and copies the root, and desktop file systems to the hard drive during installation, and then configures the system.

The “unable to lock database” is an easy fix. That one happens when another program like octopi or pacman (cli) is polling the database at the same time. However, sometime in rare cases the lock file doesn’t get removed, usually when the process gets interrupted (ctrl+z or it crashes). At any rate, deleting the lock file fixes that one:

sudo rm /var/lib/pacman/db.lck

Ref: https://wiki.archlinux.org/index.php/pacman#"Failed_to_init_transaction_(unable_to_lock_database)"_error


#25

Hmm, this is interesting:
https://wiki.archlinux.org/index.php/Network_configuration#Gigabyte_Motherboard_with_Realtek_8111/8168/8411

Could that board have the IOMMU disabled by default?


#26

That fixed it and now I have 909 updates available!!


#27

I have been through the BIOS and the manual for the MSI FM2-A75MA-E35 and cannot see anything remotely like this, no virtualisation or AMD-V. The only thing I have that is disabled are Serial and Parallel ports (don’t think I need those) and Network Stack. The BIOS manual doesn’t say what the Network Stack is for. But all looks good at this stage. Now to get on with the updates.

Thanks for the guidance so far.