Netrunner Home

Installation Rolling


#1

I will say straight off that I am no Linux expert. But after upgrading my computer from the entry-level A4-5300 to the top A10-5800K on MSI FM2-A75MA E35 mobo with 16GB Patriot Viper III DDR3 RAM I added a 250GB Sandisk Ultra 3D SSD and went ahead and installed Netrunner Rolling 2018.08.

The installation spent a long time, 20m+, at 93%, configuring. I rebooted when it completed. This took a long time before the desktop came up. But I was completely unable to get online. Internet connection was working when booted up from the USB key, also on Linux Mint and Win 7. Still the same after rebooting the modem and computer, no Internet and still taking a long time to boot up. It actually booted up quicker on the USB key. Do I wipe it and try again?


#2

Did you install using the free, or non-free gpu driver option?
If your trying to install with the Catalyst (non-free) drivers, the dual AMD gpu’s could be causing your issues.

Also that motherboard come with a built in Linux environment called Winki 3, did you already install this to your bios?
If so, that might also be causing you some issues, but that’s just speculation on my part.
I have nither an MSI motherboard, nor do I have any AMD GPU’s, especially dual ones.

https://us.msi.com/Motherboard/FM2A75MAE35/Overview

https://www.youtube.com/watch?v=d6xS73txBOM
https://www.youtube.com/watch?v=TqIe5eH5f_w


#3

I did a default install. There is no dual GPU setup on this PC, sounds like more trouble than it is worth. It is using the integrated HD 7660D. I haven’t installed Winki III. Apart from the slow bootup the only issue I have is no Internet. As I noted, I have Internet if I boot into Linux Mint 19 or Win 7. Everything else is there and functioning properly.

I have another PC to complete and will try again on that.


#4

Could you post the output of:

inxi -N

#5

I fixed the slow bootup. BIOS was set to defaults using PCIe graphics, not integrated. As both run on the PCIe bus this wasn’t an issue with Linux Mint, Win 7, or XP but only with Netrunner. I set it to integrated and Netrunner booted up fast.

Obviously I can’t post from Netrunner while there is no working internet connection but I did a screen capture of the output you wanted but there doesn’t seem to be a way to add an attachment. There are another couple of captures that look interesting too. But will have to go back in.

Internet works on the bootable USB key but, oddly, not in the installation. I suspect there may be an issue caused by graphics setting which caused the slow bootup, given the configuring phase was also very slow. I may try reinstalling now that it is set to integrated which fixed the slow bootup.


#6

You might check the md5sum of the iso image.
If that’s, good try wiping the usb stuck before burning the ISO to it.
Make sure your also not using unetbootin, or any similar utility to burn the ISO.
The Netrunner Rolling ISO like it’s parents, Arch, Manjaro, requires a raw write of the ISO image to the usb, it can not be extracted to an already existing partition, file system, like these utilities do. These are hybrid iso’s (more than one partition), that also uses file system overlays, that are required for the installer to work properly.


#7

Here is the info you asked for (both are identical):

Bootup on USB key

Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: d4:3d:7e:4e:05:0e

Boot into Netrunner

Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: d4:3d:7e:4e:05:0e

Checksum is correct. I use Rufus 3.1 to write the ISO to the USB key.


#8

I’m not familiar with rufus, but if it creates a partition, formats it, then dumps the content of the ISO’s user visible file-system to the formatted partition, then it will not work correctly. The Manjaro/Netrunner Rolling ISO, already has the needed two partitions (including a fat16 uefi partition). It needs to be written in raw mode, aka via dd, suse imagewriter, etcher, or similar utility.

https://wiki.manjaro.org/index.php/Burn_an_ISO_File#Writing_to_a_USB_Stick_in_Linux

[attachment=1140]

Also, unless that is a typo on your part, the driver loaded is different:
USB live mode: r8169
Installed system: r8168

If it is a typo, then something else is wrong your internet setup, not the drivers.
Did you click on connect in the NM applet?
You don’t have airplane mode enabled (same applet)?


#9

When I’m using Rufus I have to do it in dd-mode like AJSlye mentioned, it will not boot otherwise.
3.1 is somewhat old so you might try the latest one.


#10

I did according to the FAQ, installed Win32DiskImager for Windows and made another boot USB key. The result was exactly the same. While in USB Live mode Internet worked but as it got into the 22min long configuring phase the Internet connection dropped in and out, and that was before I booted into the installed OS. There was no Internet though everything else worked fine.

I changed the ISO to a zip and looked at the file and folder structure and found it was exactly the same on the USB key.

I had no trouble installing Mint and Maui Linux from bootable USB media made the same way.

I will see if I can do something about the ethernet driver.


#11

This is very strange, my system uses the same driver and works fine.

$ inxi -N
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be

Look under system settings > Hardware detection to see if network-r8168 is installed:
[attachment=1141]

This might seem obvious, but just to be sure.
You are checking the network manager tray applet to be sure that Wired connection 1 is enabled (connected)?
This may not be enabled by default on the installed system, especially if a wifi chip is also installed.

[attachment=1142]

The only other thing I can think of at the moment is a power management issue.
You could try disabling tlp to see if that helps, if it does you may need to add a rule for that adapter.

systemctl stop tlp tlp-sleep
systemctl disable tlp tlp-sleep

#12

Without booting back into Netrunner drive I am sure everything is as your caps. Will follow your suggestions later.

Question: Is it normal for it to spend 22 minutes in the configure stage? I wonder if there is an issue with the installer or the kernel version. If I had kept the 2018.01 Rolling I would go back and try that.

After trying to sort this out I updated my Mint Cinnamon from 19 to 19.1 which went quickly and smoothly, no issues.


#13

Yes, and No. It really depends on your hardware.
However, 22 minutes does sound quite long to me.

You posted earlier:

This tells me that the adapter is working and connected to your router.
If your not getting internet in Firefox, Octopi, Konsole, etc., then something else must be off.

To get a better feel, could you post the entire output of:

sudo inxi -Fmx

Example:

$ sudo inxi -Fmx [sudo] password for jamesk: System: Host: james-pc Kernel: 4.17.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.0 Console: tty 2 Distro: Netrunner 2018.08 Rolling Machine: Type: Desktop System: HP product: 24-g227c v: N/A serial: 8CC7030CL1 Mobo: HP model: 82DD v: 0000 serial: PGAVL0A8J5907D UEFI: AMI v: F.36 date: 06/21/2018 Memory: RAM: total: 31.30 GiB used: 4.53 GiB (14.5%) Array-1: capacity: 32 GiB slots: 2 EC: None max module size: 16 GiB note: est. Device-1: DIMM0 size: 16 GiB speed: 2133 MT/s type: DDR4 Device-2: DIMM1 size: 16 GiB speed: 2133 MT/s type: DDR4 CPU: Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 Speed: 848 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 946 2: 958 3: 1039 4: 960 Graphics: Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 Display: server: X.Org 1.20.3 driver: intel unloaded: modesetting tty: N/A OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.2.6 direct render: Yes Audio: Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 Sound Server: ALSA v: k4.17.19-1-MANJARO Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8168 v: 8.045.08-NAPI port: e000 bus ID: 01:00.0 IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: c8:d3:ff:e7:c4:47 Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8723be v: kernel port: d000 bus ID: 02:00.0 IF: wlp2s0 state: down mac: 32:63:29:07:55:22 Drives: Local Storage: total: 931.51 GiB used: 60.51 GiB (6.5%) ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB Partition: ID-1: / size: 881.71 GiB used: 60.51 GiB (6.9%) fs: ext4 dev: /dev/sda2 ID-2: swap-1 size: 34.43 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 Sensors: System Temperatures: cpu: 54.0 C mobo: N/A Fan Speeds (RPM): N/A Info: Processes: 182 Uptime: 1d 7h 43m Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28


#14

I did not see your latest post in time. I regret to say that I wiped Netrunner and installed the latest Kubuntu which was a quick and straight forward install, no issues, fully updated and additional software installed. Configure time was no longer than 20 seconds.

When I get onto the other two PCs I have to complete, which I can go ahead with now, I will try again with Netrunner as I love the polish it has.

Thanks for the effort on my behalf.


#15

No problems, please let us know how it goes on the other two systems.

PS. If Kubuntu with it’s older kernel works for you on that system, you could give our Debian based edition a try on that hardware.


#16

As a matter of fact I just downloaded it and have looked at it from the USB key. Will install it tomorrow sometime, give it a whirl. Great minds . . etc.


#17

It looks like my report on how my 18.03 installation went as was suggested to me by AJSlye as an alternative to 2018.08 Rolling got shifted to the 18.03 forum where, on its own, would seem irrelevant.


#18

Don’t know what to say, all I know is that i didn’t move it.

With that said, I think I may know what the issue is.
There are two different drivers for the Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet adapters (chipsets). One that comes with the kernel (r8169), and one that does not (linux417-r8168). On the ISO there is a mhwd overlayfs that contains the drivers needed for mhwd to detect and use the correct drivers during boot into the live environment. My thought is that once installed, your system is, for one reason or another, simply using the wrong one. You can tell if the external driver module is installed by going into system settings, hardware detection, and looking to see if network-r8168 is marked as installed.
[attachment=1143]

If it is then you may want to remove this driver, and make sure it also removed the blacklist file for the r8169 driver under /etc/modprob.d:

[attachment=1144]

Alternatively, you could try remarking out blacklist r8169 inside this file, and reboot to see if that fixes the issue first.
If it does, then you actually have a r8169, but not a r8168 compatible chip. Now, as to why mhwd is detecting it properly in the live environment during boot, and not during the calamares mhwd setup process to the installed system, I have no idea.


#19

Sorry, I thought you went with 18.03 now instead. It doesnt hurt though either, so I’ll leave it there just in case. :rolleyes:


#20