installer corrupts /home partition


I was installing Ozymandias on parallel partitions to NETRunner 14. When I rebooted the system the /home partition for 14 was not mountable by either instance of NetRunner. Any clues as to how to proceed to get the partition back to 14? When I view it with GPart or a similar tools it’s there and seems to have data. I am not sure how to proceed. :huh:

Can you manually mount that partition?

sudo mount /dev/partitionname /mnt?
Use the partitionname gparted shows like for example /dev/sda2

Btw. Which filesystem do you use on that partition?

Hello, Thanks for your response.

No to mounting. The partion is /dev/sdb running on EXT3. Manual mounting attempts all received a “permission” error. I tried mounting from NetRunner 14.2 live cd and Netrunner 16 running on my computer. Neither worked currently I am using TestDisk to scan the partition to see if something is recoverable.

The scan is running now and I will have more information later today (5/29).
I made one attempt with gparted on NetRunner 16 to “recover and repair” the partition but it did not work.
My fear is that I overwrote the actual partition table and nuke the folder structure. I will keep you posted with what I find.

Jim Adamski

  • Hope to be certified in Linux Server soon-

/dev/sdb is not a partition but the whole second harddisk. /dev/sdb1 would be the first partition.
Hope nothing is loss or if it is you have a good backup of the most important data.


So far the data is a complete loss.

1- I have taken a complete binary copy of the partition with TestDisk and offloaded it to a USB drive for forensic examination.
2- I will us test disk again to see if I chose the correct partition to examine.
3- After I confirm that I am using the correct partition, I will use PhotoRec to see if I can recover the data.

I have backups but when I looked at the dates I was shocked at how old they were. I am losing the most recent data if not all data. Lesson learned again.

I will keep you posted.