Installer crashes

I got an installer crash with message please file a new bug using ubuntu-bug ubiquity. I tried to install ubuntu-bug but the message then is no netrunner … :@

I tried an install in virtualbox and on a Thinkpad T410. The install on the T410 even shut down before finish due to temperature. This seems to be an Nvidia driver problem with KDE.

Hi svx_biker,

how much RAM and diskspace did you use?
Please make sure to give Netrunner 1500MB RAM and 16GB space to install (8GB is also fine, but then you cant do much).

In virtualbox I had 1536 KB and only 8GB. On the Thinkpad I have 4GB RAM and a 24GB Partition.

It’s a bit strange that I get the same message (crash) in virtualbox and on the physical machine. Btw, virtualbox runs on another machine without nvidia. It’s a Laptop too but from Medion.

On the thinkpad, do you have UEFI or Bios-compatible mode?
When you press F12 for boot options, there should be 2 entries for USB stick:
One “UEFI” and one without, I would recommend trying the one without with UEFI Set to legacy mode.

It’s an older Thinkpad which doesn’t have UEFI yet. So no, its BIOS.

I’m trying another install in virtualbox with absolutely no change to the installer. Only region and Country but no partition setup. On the Thinkpad I had to select the partition for installation as I didn’t want to clear all other (Linux) installs on it.

Could it be a problem with install onto a logical partition? I wanted to install on /dev/hda8 which is an extended logical drive. I didn’t specify a dedicated swap space on the Thinkpad either but wanted to use the one on /dev/sda3 (Primary partition at the end) I use for all other Linux OS.
Finally installed in virtualbox!

I guess the failure had to do with:
a) to small diskspace (only 8MB) in Virtualbox. Count some deduction for Swap and it was probably not enough.
b) on the Thinkpad I’m still a bit lost. I think the Nvidia setup makes the heating problem so I cannot find the end.

I’ve tried to install bumblebee but sometimes it shuts down even before.

Yeah you need at least 7.5 GB big root partition for it to be installed successfully. The ubiquity Installer might make a mistake in calculating the size if you only set 8 GB (non growing) virtual harddrive in virtualbox. (It splits swap and root partitions in such a way that at least 1 GB SWAP is created but this would cause only 7 GB to be free for the system to install to but it needs at least 7.5 GB for the install. Officially we say 8 GB is the minimum)
So like recommend on the downloadpage use 16 GB for the virtual harddrive and you should be good to go.

When it comes to installing on the real machine excessive use of extenden partitions could make a problem as to various limitations of the legacy bios and harddrives and so on.
But also make sure to have enough free disk space on the partition. I would recommend at least 10 GB otherwise you pretty sure might run into a space problem very fast when installing some other apps or storing some music or video files.
If it still fails. Please take a look at the syslog in /var/log right after it failed. It should contain more ubiquity debug messages.
Otherwise there are other methods to obtain the installer log:

So I got it installed in virtualbox and on the T410 - but … only in English.

When I choose german (Deutsch) the installer fails after some time with message
ubiquity: locale: Cannot set LC_CTYPE to default locale: No such file or directory
ubiquity: locale: Cannot set LC_MESSAGES to default locale: No such file or directory
ubiquity: locale: Cannot set LC_ALL to default locale: No such file or directory
ubiquity[2218]: log-output -t ubiquity setxkbmap -model pc105 -layout -option
ubiquity[2218]: debconffilter_done: ubi-cosole-setup (current: ubi-console-setup)
ubiquity[2218]: dbfilter_handle_status: (‘ubi-console-setup’, 141)

Hope you can localize the problem and it helps other installers.

Do you have internet connection configured during the install? (as it would try to download the german language packs during install then)
And the language pack needs a little bit more space aswell. I will try to reproduce it.
So far I failed

Yes I have internet connection but somehow it seems to fail getting the necessary packs.

Does the install work without internet connection?

Good question. I didn’t try that.

In virtualbox I have internet connection from the host anyway and on the thinkpad I configured the WLAN settings. Doesn’t the installer require an internet connection? Or is that just a warning if you don’t have one?

The installer does not need an Internet connection to work.

Ok, I’ll try without internet.

What I see already is that I now have Country=Germany. With internet I get Country=Switzerland and I know we have a different locale (de_CH vs de_DE). Maybe that was the problem.

I’ll let it run and report if it installed without crash.

Edit: When I try setting the keyboard (only) to Switzerland I already get an installer bug: Could not find text for Switzerland see bug 1182784. Here at least I can switch back to German without getting a hard crash.
Install finished ok! :slight_smile:

Btw, it’s probably the same issue with french (Swiss french) and italian (Swiss italian) but I didn’t try those.

Although a relatively small country we have German, French and Italian and every sub-region has its own keyboard and locale setting.

Yeah this is a known bug also in Ubuntu and needs more investigation by us all to be fixed. It seems to affect only a small bunch of keyboard country combinations. Thanks for reporting.

Interesting! Is it related to KDE? I’ve also installed Ubuntu (Mate & Unitiy) recently and I cannot remember that I had an issue with German (Switzerland).
Just got the same error with Kubuntu when installing with internet connection.

However, I didn’t have this issue with Mate and Unitiy. So this must have something to do with the setup in Kubuntu.

I guess it has something todo with the kdeui component of the ubiquity installer.