Installer fails to recognize EFI partition


while trying to map partitions during the install, the installer doesn’t recognize /dev/sda1 as being my EFI partition (see attached screenshot). The file system (FAT32) is shown as unknown. I cannot select the mount point /boot/efi and am forced to reformat (which I don’t want to do). The esp marker is well set and recognized.

Can you advise?

Best regards


Did you try the bottom option in the installer, to manually partition? On that screen select the system partition (i.e. NOT /dev/sda1, /dev/sda3 maybe?). You may need to fiddle with Grub manually after install, but it looks like your multiboot requires this anyway.

This is what I did, and the EFI and Swap partitions were left alone – functioned properly without needing installer intervention.


The error disappeared when I re-run the installer. All FAT/NTFS partitions were well recognized then.



Today we also updated the ISO to include Calamares 3.0, which could fix those problems.