Netrunner Home

Installing Netrunner 19.01 Desktop onto an SSD with an RTX 2080? [solved]


#1

How would this be done? Whenever I try booting into the installer via USB this is as far as I get:


I tried adding “vga=normal nomodeset” to the end of the linux line by pressing E to get to the advanced options in the screen before that one, but it still ended up not booting the desktop.


#2

What happens if you type in startx in that commandline prompt?
I assume you graphicscard might be not supported


#3

With or without “vga=normal nomodeset” I get this after trying startx:


Also yes, I’m pretty sure my card isn’t supported by the nouveau drivers. Least not until Linux 5.0. (from what I’ve read)


#4

Would it be easier to maybe clone my current installation and put it on the SSD? Though… minus the extra stuff I have? Target is a 256GB SSD and the HDD with Netrunner on it currently is 500GB with 404.51GB used. Is there a cloning program that can choose what to transfer and what not to? I was going to use the 500GB for everything extra like game installs and whatnot.


#5

Not sure how this would help. The issue is that you need a newer Kernel that we do not provide as live media. If you manage somehow to start the graphical user interface by forcing vesa mode (which should work on every card in theory) you could install the system and install a newer kernel later on or even try installing the proprietary nvidia driver and see if it helps.

It is a bit complicated to clone your installed system. It could work via dd’ing the whole system but that usually needs the same size of target hard drive.


#6

I was contemplating replacing the (spinning) HDD with a SSD.

The system requirements don’t mention anything specific.

In order avoiding technical challenges, are there any particular requirements for installing Netrunner to a SSD?


#7

No there is nothing particular to think about when installing on a SSD


#8

Good to know, thanks.


#9

Alright so I finally got around to taking out my 2080 and putting back in my RX 580 and installing Netrunner on the SSD, like I wanted. Only problem is… it won’t boot. I have Windows 10 on my NVMe, Netrunner 19.01 on my 500GB HDD (currently using), and a fresh install of Netrunner 19.01 on the Samsung 850 SSD. When I boot my PC, Windows starts automatically, like I want. If I go to my boot menu and select the 500GB HDD, it boots this version of Netrunner. But if I select the 850 SSD with the fresh install, it boots to Windows. I can’t for the life of me figure out why… Any suggestions? I just need them both in my PC long enough to copy over what I wanna keep from this install to the fresh SSD install.


#10

Seems like the bootloader on the 850 ssd is not installed or broken and it skips this hard drive and boots straight into Windows then.
The question now is why there is no bootloader on this ssd. Have you installed the bootloader specifically on this ssd?


#11

Yes, and I more or less figured it out. There were two entries for this SSD. One was just the name of the SSD (Samsung SSD 850 or something like that) and the other was “debian(Samsung SSD 850” or something along those lines. Choosing just the drive didn’t work, but choosing the one with debian on it did for whatever reason. Either way I have Netrunner 19.01 installed on the SSD and it boots just fine, so I suppose the issue is solved. Thanks for all the tips.