Netrunner Home

Installing wine


#1

Hi, trying to install wine on 18.03. I’ve added the i386 architecture. I’ve tried installing from the standard repo and from wine-hq using their added repo.

I read something about forcing a specific version of libfontconfig1 and libfontconfig1:i386 but to no avail (behaps I’m doing something wrong there).

Anyone have wine running on 18.03? exact steps to git’r done?

Thanks

Basically, the rabbit hole just goes through the list of dependencies with an example below…

The following packages have unmet dependencies:

 libcairo2 : Depends: libfontconfig1 (>= 2.12) but it is not going to be installed
 librsvg2-2 : Depends: libfontconfig1 (>= 2.12) but it is not going to be installed
              Depends: libpango-1.0-0 (>= 1.36.0) but it is not going to be installed
              Depends: libpangocairo-1.0-0 (>= 1.36.0) but it is not going to be installed
              Depends: libpangoft2-1.0-0 (>= 1.37.2) but it is not going to be installed
              Recommends: librsvg2-common but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

#2

I don’t have any problem on a clean 18.03 to just sudo apt install wine
It will automatically pull the wine32 package and everything else necessary to run wine.

Do you have any other third party repos activated that might interfere?


#3

Thanks for the speedy reply. No, no added repo other than winehq… but this problem was the reason I added the winehq repo so was an attempted solution. Nothing out of the ordinary installed – just the updates, Terminator, filelight, and kpat. It’s a pretty new install on physical hardware.

My guess is something in either the initial install or the updates was corrupted in the process. I’ll redo the process beginning with a new copy of the ISO, and I’ll play around with it a bit in virtualbox as well to see if wine will install before updates, after updates, etc., and see if I can find exactly where the system went out of whack and whether this condition can be reproduced.


#4

Alrighty then,

Is there a specific i386/32bit repo which needs to be added? None of the instructions I found online mentioned adding a repo except for an old 11.10 ubuntu page.

clean attempt: after clean reinstall (before updates), adding the i386 architecture with dpkg, then sudo apt update, I got the message that Netrunner does not support 32bit (paraphrasing a several line message). I went ahead and tried the wine install, and it does pull in all the 64bit wine/dependencies but definitely not the 32bit.

I’ll do another install later and catch all the messages, but figured perhaps a a simple repo addition may be a cure.


#5

Hmm I did not add the i386 just installed the wine package which grabbed the wine32 package aswell and auto adds the i386 architecture to dpkg.
Then wine works like expected for me.


#6

It seems the only difference is my manual addition of the i386:

sudo dpkg --add-architecture i386

I never actually thought to – just install wine. I’ll try it that way on the next attempt.