Issue loading/running Chrome

I’m new to both Linux and Netrunner, so any suggestions need to be explicit without lots of abbreviations, skipped steps, assumptions, etc.

I have successfully installed and run Chromium, but get frequent Aw Snap screens. So I tried to load Chrome from Google’s website. It appeared to install fine. But it would not run. Clicking the icon caused the Chrome icon/title to flash for a few seconds on the status bar (or whatever it’s called at the bottom of the screen) and then disappear. That’s all.

Furthermore, and more troubling, when I tried to subsequently open Synaptic Package Manager, I received an error dialog box with a message that read in part: E:dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to
correct the problem. I also tried to remove Chrome manually using sudo commands and received a similar message. So I gave up, reloaded Netrunner 14, tried to reinstall Chrome (again from the Google website) with the same result.

I strongly prefer either Chromium or Chrome because of the synced history across many devices and other factors. I need to get one or the other working decently, if not well, otherwise this is a dealbreaker for me. I tried Kubuntu 14.10 before coming to Netrunner 14 and was able to successfully install and run Chrome without hassle. I may have to go back to that, though I reallly like Netrunner’s features, unless someone can help me. Any suggestions would be welcomed.



Normally I would recommend chromium. Are there particular pages were it crashes?
As for chrome. Have you tried doing what the dpkg message suggests?

Thanks for the reply. The page that causes the most trouble is my Google+ page. I have yet to get it loaded with Google Hangouts running successfully. This is problematic because I frequently use Google Hangouts to collaborate on projects with groups of people.

Unfortunately, I’m so new to Linux that I only know a very few terminal commands (sudo, cd, etc). I’m finding the learning curve extremely steep. I’m spending about 10 hours troubleshooting for every hour of productive work. It was easier and faster to reload Netrunner 14 than try to learn the nuances of dpkg.

Now I’m trying to load a software package (KMyMoney 4.7.1) from a tar.xz file (it’s not in the repositories yet). The README files assume so much Linux knowledge that it has been impossible for me to follow them successfully. Ironically, I was able to load the Windows version on my Windows laptop with just a few mouse clicks. So far I’m finding my Linux experience to be extremely frustrating. I want to get off Windows, but this experience is very much deterring me.

Sorry for the rant. Maybe if you could point me to some tutorials or references that can get me up the learning curve a lot faster. Even using the help function on the terminal commands generates lots of terminology I don’t understand. It would also help to better understand the Linux file structure.


Kmymoney is in the repositories:

sudo apt-get install kmymoney

However this is not the 4.7.1 version, Is there a reason why you need the latest released version?

The tar.xz file you downloaded is the source code package, however with your admittedly limited knowledge would have a huge learning curve trying to compile and install this and probably not a great idea as we can;'t offer support for packages installed in this manner. Normally I would suggest that if you want to use the latest up to date versions of your software, that you have a look at a rolling release distribution like Netrunner Rolling (Manjaro), but until you think your ready for such a distribution I would just use the version of kmymoney that is available in the Netrunner Standard (Kubuntu) repositories.

Thanks AJSlye.

There’s two reasons I wanted to use 4.7.1. First, I had recently updated my Windows laptop with this version and was used to it. Second, it has several improvements to data import over 4.6.x versions and some data tagging features not present in earlier versions. I’d lose some of my tags because they would not be saved in the 4.6.x version. So now the question is, what versions show up in repositories and how long does that take after the version is released?

BTW, I’ve made some progress on the original Chromium issue. After a bit of research, I cleared the cache and Chromium has been better behaved. (Should have thought of that.) I even was able to start Google Hangouts. I’m crossing my fingers and hoping for the best that this will continue.

I’m still looking for some good tutorials or references that will get me up the Linux learning curve as fast as my brain can handle it. I’m old enough to have punched cards in FORTRAN, so I’ve been around computers a while. I just need a good overview and a place to get the details as needed. Any suggestions?

Since Netrunner 14 is based on Kubuntu 14.04 LTS, the packages in those repositories are supported for 5 years, they only receive security and bug fix updates, with the exception of a few applications like Firefox, Thunderbird, Skype, etc.

There is however a PPA for kmymoney here:

Now Netrunner Rolling on the other hand is based on Manjaro, which means that because of It’s rolling nature already has Kmymoney version 4.7.1-1 in their repositories. Netrunner Rolling (Manjaro) receives update-packs every two to three weeks on average, so your always running the latest versions of your installed software.

Thanks again, AJSlye:

I successfully downloaded and installed the 4.7.1. package from claydoh. (I didn’t even know PPAs existed until I read your post.) I think I’ll stick with that route for a while until I get my Linux feet on the ground. After I’m more comfortable with the whole environment I may try graduating to “Rolling.” If I understand correctly, the “pro” of Rolling is the access to the newest package versions, but that may come with the “con” of decreased stability. Are there other pros and cons to be aware of? I’m using a “repurposed” net book [Acer Aspire One KAV60, dual core Intel Atom processor, 1 GB Ram, 120 GB SSD] to experiment with so my hardware is a bit limited.


Not exactly, the Manjaro stable branch in which Netrunner Rolling is on is more of a semi-rolling branch of Manjaro, the packages are vigorously tested before making it to the stable branch, here is how it works:

Arch Linux receives and compiles updated packages, they then go into testing after a couple of days they end up in Arch Stable (here there can still be regressions and instability due to the Arch Linux philosophies.), At this point Manjaro syncs thier unstable repository with the Arch Stable repository (this happens daily) checks that there are not any dependency issues and then pushes them all to stable, they are now tested further for stability and to again make sure there are no breakages, regressions or missing dependencies, once the packages in this repository are deemed a being stable (this usually takes approx. 2 to 3 weeks on average), the packages then move to Stable where you get them from.

These extra steps ensure a very stable system to the end user. Yes while the software on Netrunner rolling are newer than what is available in Ubuntu, they are not going to give you a less stable system.