kamoso error

I’m getting this:

kamoso: error while loading shared libraries: libnepomuk.so.4: cannot open shared object file: No such file or directory

Yeap. I am having the same message as welll

I believe this has something to do with the move to baloo, but I’m not sue if this would just need a recompile or if it is an upstream issue.

it seems like it got something to do with nepomuk though…

Yes, in KDE 4.13 nepomuk was replace by baloo.

if i run the mplayer script, the camera is working fine. This issue might be a Kamoso bug? hhmm…

Yes, it maybe a bug (upstream issue) or it might just require a recompile against the newer libraries.

Also you can safely remove nepomuk-widgets (which have been depreciated and replace by baloo-widgets upstream), the netrunner-desktop meta (which currently requires nepomuk-widgets) & also remove (then re-install) nepomok-core (which has been upgraded for use with baloo).

Go well my friend,

Well it seems that you are right. nepomuk-widgets has been removed from the blueshell repo. I have removed nepomuk-widgets, nepomuk-core and netrunner-desktop, kamoso still not able to run somehow.

Luckily I am able to get nepomuk-widget from the AUR and restore my settings.

Let’s see how dev going to tackle this issue.

It’s a bad Idea to install nepomuk-widget from the AUR as it has been discontinued/depreciated upstream (version 4.12.4-1), It has been replaced by baloo-widgets (version 4.13.0-1) which is installed by default from the extras repositories.

I will try to check it again once I have my hands on my laptop. :slight_smile:

both baloo and baloo_widgets have been installed in my system. :slight_smile:
Seems like netrunner_desktop still depend on nepomuk_widgets in order to work.

netrunner_desktop is just a meta package, it only exists to install other actual packages, it is not required for your system to work.

I uninstalled netrunner_desktop and found out that the menu (when right-click on the desktop) will be affected.

OK, the Netrunner team will need to remake this package with baloo-widgets as a dependency instead, but until then in a terminal run sudo pacman -Sdd netrunner-desktop this will ignore the dependency and install anyway,

Yeap. Done that and it work pretty fine right now. :smiley:

Thats not true. Actually its the netrunner desktop containment. We don’t have a metapackage for the netrunner desktop.
We are currently working on a solution that will come next week.

Thanks for the update :wink:

I sincerely apologize, after actually looking inside the netrunner-desktop package I realized it was much more than what I thought it was, I’d like to thank you for the correction and I defiantly want to extend a great big thank you for working on this issue, I’m sure we’ll all be looking forward for your fix.

Go well my friend,

After some more research on this issue it seems that some KDE based apps still depend on nepomuk, however nepomuk-widgets is not required for any that I found so far, please re-install nepomuk from the AUR and then in a terminal type:
sudo ln -s /usr/lib/libnepomukcore.so.4 /usr/lib/libnepomuk.so.4

PS. Please let me know if this gets it working for you again, it did for me.

UPDATE: with the new netrunner-desktop package installed we can now remove nepomuk, nepomuk-widgets and all related packages, after they are removed you’ll just need to make two links so that your apps still requiring nepomuk (like kamoso) and/or nepomuk-widgets will run without error:

sudo ln -s /usr/lib/libbaloocore.so.4 /usr/lib/libnepomuk.so.4
sudo ln -s /usr/lib/libbaloowidgets.so.4 /usr/lib/libnepomukwidgets.so.4

Go well,

PS. Maybe one of the developers can add making these links on the system by one of their netrunner packages.

Thanks buddy for the update! :smiley: