KDE Daemon Password?

“Rolling” release x64 – live session.

Has anyone yet managed to configure a mobile broadband connection without interference from the KDE Daemon asking for a password that doesn’t exist? :slight_smile:

When I plug in my mobile broadband USB modem it is recognized and I can configure my account details from those available. On requesting “connect”, the modem dials out and finds the network but cannot connect to it. Instead I get a popup from the panel stating the IP configuration was not available. Shortly after that, another window appears in the middle of the screen from the KDE Daemon requesting a password that doesn’t exist because none was ever set. If this is meaning the password for the net connection, then this doesn’t work either and the window keeps repeating. I tried looking for the KDE Wallet settings but although the icon is there, the configuration details are “missing” from the account section.

I can configure my DSL connection fine without these issues but am reluctant to make a full install. The reason being I did install the latest Kubuntu LTS two days ago and it worked fine for almost a day until I started getting KDE Daemon password requests for the DSL connection that had already been configured and up to that point was working fine. This effectively locked me out of the internet so I uninstalled it.

Does anyone have an answer?

The password for the live image is manjaro for both user and root.

I hope this is what you needed brother…

On the 64bit version user and root password are not set. So just pressing enter should work here.

Thank you both for responding but I was already aware of the “manjaro” password. Entering nothing, manjaro, or anything else for that matter into the Daemon box has no effect. The net result is this password request window keeps returning and so do the network manager tray pop-ups for either “Modem ttyACM0 IP configuration was unavailable” or “No secrets were provided”.

try this:
sudo systemctl enable ModemManager
sudo systemctl start ModemManager

Also make sure your provider is provided in this package: