KDE pulse audio problems

I, suspect this is a KDE, issue as I’v seen it on multiple KDE distros. The problem, I’m have is that most of the time I boot up, KDE is asking me if I want to forget about some devices, so I elect to manage them. There is a very long list of devices and some are repeats.
The list includes My Sound card and my Nvida HDMI. I know how, to turn the nvidia, off with pulse volume control, as I’ve been doing this for years. Yesterday, again pulse had stopped working until I set it up again.
I’ve seached and looked for a file to delete or rename, to get rid of about 20 divices and haven’t found, what it is.
Again, strictly a KDE issue, I think.
All. I want is my sound card operating in 5.1 surround, but I can’t get it to stick.
Also in Phonon, under hardware congiuration, it shows,my nvida HDMI as, off, as it should be, but when, I select my sound card, and try to hear individual apeakers, it doesn’t work and that does work, in other KDE distro’s.
My sound card is a Creative pro something or other, but I’m sure my hardware is not the issue.
Any Ideas?

Are you sure that pulseaudio is running ? When pulseaudio is running it should hide all the alsa devices.
By default Netrunner only shows the ALSA devices as PA is not shipped.
As for the soundcard dissappearing message you can get rid of it by checking “don’t ask again”.
In KDE Plasma Desktop 4.11 this issue has been almost fixed as you only get one warning and not a dozens.
All in all it has todo with ALSA and its handling and labeling of audio devices so the Phonon dialog asks ALSA to show the list of available devices and alsa gives it the long list you see in phonon.

I can hit test in phonon, and it plays fine.
I just counted and I have 42 devices listed.
This is a kde BUG. One of my OS’s, I boot to is Kubuntu 12.04 LTS, and I’ve never updated anything, besides the normal updates. I have not added any PPA’s for newer KDE.
There is not an issue in Kubuntu 12.04. I’ve been doing, Pulse setup for awhile and again, there is no issue with older KDE. Yes, I know how to tell KDE, not to ask again, but doesn’t fix it. Loging in today, I had no, sound, until I set it up, again
So, either a KDE issue or Netrunner Issue.
I have minor problems, in PCLinuxOS 2103 KDE, but nothing like this.
I, see another guy with my soundcard here: http://forums.netrunner-os.com/showthread.php?tid=1124
Look at his device list in the thumbnail. Him and a few others.
It is not the, card, casue it works fine everywhere else.
I’m hoping a KDE update will fix it. :frowning:

It is not an issue with KDE to be exactly but either with pulseaudio.
Pulseaudio should hide the alsa devices automatically. Please try reinstalling pulseaudio with

sudo apt-get install --reinstall pulseaudio.

I tested this btw. and it works fine here. Please make sure that the files /usr/share/alsa/pulse-alsa.conf and /usr/share/alsa/alsa.conf.d/pulse.conf are installed. (they normally ship with the pulseaudio package)

That would be thes two attached.
I have attached and it tells me, both files are there, but it won’t let me attache them.
I’m trying now, with them open in kwrite, from my desktop,with print scrn.
I have already, completely uninstalled and reinstalled pulse.
Hopefully, you can see my files.

No I can’t see those files.

Sorry leszek,
I tried everway, I could think of, including ksnaphot to get you the files, but they are there.
I completely uninstalled, everything including configuration files.
Those that were left, the ones you mentioned and pavacntrl, I renamed, to -old.
After that I reinstalled everything and rebooted and set it up again turning off my Nvidia HDMI, like I always do, as I’m not using an HDMI cable.
For, the moment it’s working, as it did before. My son is a Linux Sytem admin, but I didn’t bother to ask, as I knew he would say: Dad uninstall everything and start from scratch. I’m 68, but have been playing with this stuff, for awhile now.
I’m not critizing Netrunner, he said try it, and I like it, but have found a few problems.
I hope, it remains fixed, but I’ll have to see at this point.
Thank you very much for your time and assistance, and I hope you can add a spell checker, cause I’m horrible at spelling.
I let you know if pulse keeps running or if it doesn’t.
Again, my thanks.

As an update to this post, Netrunner is using, KDE – Desktop (4.10.3) to quote from the site.
There are something like 70 fixes from 4.10 to 4.11 and many involve Pulse Audio.
So, I disagree, that the problems are with pulse. What, I see in Netrunner, I really like, but I’ve never had a piece of hardware or software without an issue.
I like Netrunner enough to point out, problems. In the meantime, I put Kubuntu 13.04 which has newer KDE and those issues are gone.
I will definitely be looking for the next release or KDE upgrades for this one.
I love, what I see so far!

If you update Netrunner you will get KDE SC 4.11 .

Now, you tell me. I update every OS, everyday.
Is it, in normal updates or do I have to add a PPA.

Thanks, I shall investigate, but my point about KDE eariler , was correct.
Thanks, and point me to the update. I did attempt to reinstall, just to make sure it wasn’t something, I had done.
When I did, the installer crashed, when I attempted to mount some ntfs and fat 32 partitions. I left those alone and got it to install, thinking I’d mount them afterwards. Pulse had the same problems and steam would not launch. Maybe my DVD got corrupted, but I did do a MD5sum checkwhen I burned it, perhaps I damaged the DVD. Oh, and steam games no longer worked. I don’t game, but I think it’s important for Linux. That’s when, I said enough. Like everyone else, I make mistakes, I’ll reburn and recheck the Md5sum.
Thanks again, for your efforts.