kdeconnectd not running at system startup

I noticed that kdeconnectd is not running at system startup,
so that one has to start the kdeconnect kcm to get Kdeconnect up and running.
Does anyone else have this issue?

AFAIK, the kdeconnect daemon loads and unloads via sockets with systemd.
The point of the kcm is to access other devices found that are running kdeconnect.
Kdeconnect is not setup by default as an always on access to local devices, if you need this functionality you’ll need to setup systemd to load the deamon at startup.

Could you please try this version? It is up-to-date from git. Install and restart as usual, and see if it will start on system start-up. Thanx


@gericom, this is NOT a git vs officially released package issue.

@Gyges, I checked on my end and the daemon is running after login. The KDE connect daemon should be loaded by default via /etc/xdg/kdeconnectd.desktop. Please make sure you have this file, and that the daemon is running. You can use Ksysguard after start up for this:
If you have this file but the daemon is not loaded after the user logs in, then we will need to have a look to see why.
If it is running, than what exactly are you expecting it to do?

The file /etc/xdg/kdeconnectd.desktop does not exist on my installaton.
About a week ago I installed the latest Manjaro KDE Iso to my old 32 bit Laptop and its setup of Kdeconnect works flawlessly. That means that kdeconnectd is running at startup and the Kdeconnect icon appears automatically in the systray if a mobile device is paired to Kdeconnect.

UPDATE: I just checked another installation of NR that I did with the latest Iso yesterday. Same picture there, kdeconnectd not running after startup.

That is strange, the /etc/xdg/kdeconnectd.desktop file is installed with the Kdeconnect package itself.
However, we have the system tray icon deactivated by default in Netrunner Rolling.
To turn this on, right click on the system tray and select system tray settings, scroll down and check KDE Connect, then hit apply.
KDE Connect is set to auto by default and will show up under the system tray arrow, if you want it to show all the time then you’ll need to click on entries and change it to shown.

This is strange indeed.
After activating KDE-Connect via system tray settings > general > additional entries and rebooting, kdeconnectd is up and running and providing the system tray icon (because KDEconnect is paired to my phone), but still no

[color=#333333][size=small]That file is provided by the upstream kdeconnect package:[/size][/color]

Something had to have removed it, try reinstalling the package.

@ AJSlye: You’re right, kdeconnectd.desktop exists. It’s in /etc/xdg/autostart, not in /etc/xdg, so I overlooked it.
So once activated in system tray settings > general > additional entries, KDE-Connect works as expected.
However, at least to me it’s far from being intuitive that autostart of KDE-Connect is triggered by activating it in system tray settings. In addition, KDE-Connect provides background functionality (such as mute on call).
Therefore I would like to suggest to activate it by default. The only downside I can see is the RAM usage, but that’s only around 10 MB which sounds pretty reasonable to me.
What do you think?

It should be active even without the system tray widget running, it just won’t be prior to the user being logged in.
To check this re-disable the widget, restart your system, log in and open ksysguard to see if it’s running:

I did some more testing and here is what I found:

  1. After installing NR kdeconnectd isn’t running.
  2. The kdeconnectd process can be invoked either by opening the KDE-Connect KCM or by activating the KDE-Connect widget in the system tray settings.
  3. If you just open the KCM, pair with your device and reboot, all the functionality that KDE-Connect provides will not be available due to kdeconnectd not running until you open the KCM again.
  4. The only way to provide this functionally permanently is to activate the KDE-Connect widget in the system tray settings, which from my point of view is not quite obvious.

So my conclusion would be:

Once the user actively decided to use KDE-Connect and paired with another device,
its functionality should be permanently available.
I think the easiest way to achive that is to activate the systray widget by default, but maybe there is a way to only trigger the autostart of kdeconnectd after pairing with a device.

I’m not exactly sure what is causing your issue, on my system kdeconnectd is running at login without the systray widget.
It’s not meant to automatically pair your devices though, that would not be good from a security point of view.