Keyboard layout reset after reboot.

As in topic. After each reboot I need to change keyboard layout to get my local layout set.
I’m not sure what what kind of info can be helpful to resolve this problem but I’m eager to provide anything you ask.

Thanks in advance:)

Is the correct keyboard layout set in systemsettings?
How did you set your keyboard layout initially (during install)?
And how do you set it currently (what tool do you use)?

It seems that it is marked correctly in system settings. It is enough to change to different one, select back to previous layout and everything is working correctly. Until the reset.
During install there was step in installer to choose layout.
To change layout im using default kde system setting app.

Then it is a strange behavior.
Have a look here
Especially the change permanently option with kbctl.
Hope that helps.

Lezsek, Manjaro has not fixed the security certificate issue for the Wiki pages yet.

kuromo, We integrated Manjaro Settings Manager into System Settings even more than Manjaro did.
You need to fist look at the languages that are set under System Settings > Account Details > Locale
The check the settings under the first keyboard layout tab in input devices.
The second keyboard tab (KDE Default) under input devices only works for the plasma desktop, this one will not be persistent without changing the way Plasma handles sessions under System Settings > Startup and Shutdown > Desktop Session.

Languages in Locale are: english for language and messages, polish for the rest.
I tried to remove all settings by deleting .kde and .config folder in home directory but it didn’t help.

I also noticed that it wont keep session layout after logout.
Im thinking about reinstalling ;/