kwin_rules_dialog is not responding

I’m running four virtual desktops and would like to constrain certain applications to specific desktops. I’ve done this before in KDE, but it was quite some time ago.
When I try to do this the process hangs with a dialog box that has the following message.

This configuration dialog allows altering settings only for the selected window or application. etc…

I cannot get past this point and furthermore, I can’t get rid of the dialog box or the ‘Edit Application-Specific Settings’ window either. A ‘Warning - Window Manager’ dialog box eventually pops up but pressing the ‘Terminate Application kwin_rules_dialog’ button does nothing.

To reproduce.

  1. Right click on application window title bar.
  2. Select ‘More Actions -> Special Application Settings’.

I rather like having Clementine always opening and staying on Desktop 4 as it keeps things organized and when I click on its tray icon I’m taken to the correct desktop. I might assign other applications to other desktops but first I’d have to get this working.

Any suggestions?
Thanks

It’s working fine here:
[attachment=1123]

Thanks for the reply.

Still not working here. It would seem that something is preventing me from being able to actuate the ‘ok’ button either on this or on subsequent child processes, which is why I can’t terminate the process with the pop-up dialog but I can if I open the ‘System Monitor’ panel and select it.

So it appears to be some sort of a window / panel focus issue.

I installed Netrunner just recently (really like it, wish I had come across it sooner!) and the desktop subsequently loaded up with Plasma settings from an old OpenSUSE installation. Afterwards I went into the ‘System Settings -> Plasma Tweaks -> Look and Feel’ and selected Netrunner Rolling, which seemed to do the trick. This may be a clue, as when I would try to do this same thing with the previous distro it would actually hang the entire window manager and not just the process. So it may be a lingering configuration setting. Any suggestions how to clear out all presets (directories, files) and start with a fresh KDE configuration that’s stock from Netrunner?

Well, if you used your old home directory, that’s more than likely where your issue is coming from.
Back up then delete your .config, .local, and if it exists .kde directories, logout and back in, and try again.
If that works, then pull in (copy) the settings from /etc/skel to your home directory, and you should be golden.

Thanks for the directions.
I did as suggested but there was no difference, so I switched back to the old directories.
Do you suppose it could be a video driver problem? I have a Radeon 6800 series card. It doesn’t seem like this behaviour would be driver related though because it only affects this one particular situation. For some reason I can’t click on the ‘ok’ button and pressing the enter key when that window has focus doesn’t have any effect either. I can move the dialog boxes around and continue using without problem whatever window I was trying to change the settings for but I can’t seem to get at the pop up box.

By the way, I just tried it with the ‘More Actions -> Special Window Settings’ dialog box and it does the same thing as the ‘Special Application Settings’ box.

Did you install using the free driver option (default), or select the non-free driver option?
It could be any setting really, it could also be something else.
After backing up those old settings did you delate everything in your home folder or just those settings?
Did you install keeping your old home directory, or did you keep the entire / directory without formating?
You could try going into system settings > display > compositor and change the opengl settings there.
You could also be experiencing the dri3 issue that has been reported on Manjaro’s forum.

Since I can not replicate this problem, it’s hard for me to diagnose. I do tend to buy Intel only based machines. This is more of a reliability issue for me than anything else though. I’ve had too many issues with NVIDIA, and AMD (ATI) based cards over the years to trust them for what I need them for.

Later today I’ll try creating a new account and see how that works. At the very least it will determine if the problem is with config files or with something systemic. I’ll let you know how it works out.

I created a new account and it worked fine, so I knew it was a problem with cruft in my home directory.
I went through and deleted almost all of the hidden files and folders in my original account and now I’m logged in and the problem has disappeared. I’ve had to redo a bit of customizing but that’s no big deal because most of Netrunner seems to be set up pretty well for me.

One unrealted question I have is if I can get the cursor to disappear when I’m typing in a web browser like I am right now. I know that it will do this in Kate, so I suspect that it has to be supported by the application; am I right?
I may have some other questions as I get things set up again.
Thanks for the assistance.

Most of our settings are applied automatically, but the ones are under /etc/skel are only applied to new accounts.
All you need to do to have all of the default Netrunner settings is to copy the content’s of /etc/skel into your home directory:

cp -R /etc/skel/* /home/<your_username>