Last Vlc update breaks Convert.

Use to convert mp4 to Divx compatible player avi format for my tabletop dvd player so can watch on the TV.
Recently now results are horrendous blocky,jerky,stuttering. Looking at the codec all seem normal.

But when I look at the settings of convert I see

The muxer is missing. Using this profile will fail. And in a way it does.
Can start with a 500mb mp4 file and end up with a 200mb mess that is unwatchable.

Any solutions or ideas to fix? As my tabletop DVD player doesn’t play mp4

You don’t have hdmi out? j/k. :wink:

See if you may have one or both of these packages missing:

Have no issues playing mp4 in vlc. It’s the converting to Divx Avi format. Which always worked before but not recently. Like last month or two. As haven’t used the convert during that time.

Only question that pops out is the media info above saying Codec: H264 - MPEG-4 AVC (part 10)
And 2nd image in this post shows a libx264-10bit library that isn’t installed. Wondering about that?

Library for encoding H264/AVC video streams. 10bit-depth.
Provides libx264 x264-dev
Depends On
Conflicts With
libx264 x264-dev

Otherwise am at a loss why it isn’t working right anymore.
As have vlc 2.2.0-2 showing installed.

MPEG-4 Part 10 is h264 so unless you need the 10bit encoding I don’t believe that is the issue.

It does look like your input file may not be compatible with the output profile your trying to use.

I just pulled this from the VLC wiki:

Note that when you decide your transcoding settings, only some container formats (muxers) can support some codecs - look at streaming features compatibility matrix to see which supports what. If your current format is incompatible with the muxer you desire, then you must transcode it to something compatible, or choose a different muxer. If you choose an incompatible stream for a given muxer, it may silently fail. You can look for error messages in the messages window to help you debug the failures.[/quote]

Try changing the profile by selecting them one by one until the message at the bottom of the first preference screen disappears, I had to use Video - H264 + MPEG-TS for it to succeed with some of my input video files.

Sorry way over my head. Like I said always used in exact same way. And zero issues always a watchable and great results with any mp4 to Divx avi before. But will verify with a youtube mp4 to format and check difference between this mp4 and youtube mp4 as a possible reason.

Strange as seems same except stream0 is swapped with stream1 Video Audio tracks. Framerates and resolution are of course different.

Compared to top graphic I posted.

I apologize, this does seem to be a bug:

If you haven’t cleared out your pacman cache, you could try rolling back VLC.
Make sure that afterwords you add it to you pacman.conf files ignore list or it will be upgraded again.

PS. I’ve tested the older package and it does work properly.

Just in case your pacman cache has been cleared, I have uploaded the older 64bit package to my dropbox here:

Damn your always top notch helpful. A Prince of the Realm!
Thanks for your always helpful touch that makes Netrunner Rolling what it is!