Latest Firefox. how?

I’ve realize that my FF version stuck in 34.0 not move on… but current version is 39. According to manuals I have just

sudo apt-get upgrade firefox for upgrade but this thing says that I have the lattest version. :huh: Is for netrunner upgrade process different? I’ve found plenty PPA with the lattest versions but they lets say too lattest… just nightbuilds or beta. :smiley:

Hi Slimy,

please look here how to always get recent plasma-enabled mozilla firefox and thundebird:

Just cant update it because dependency issue… :-/

How about uninstalling firefox-kde and firefox-kde-support first, then reinstalling?

Seems like it was muon bug… it just can’t choice a version. but with apt-get everything works

It doesn’t work for me, I stuck with version 37.0.1
I removed Firefox and did

[code]sudo apt-get update

sudo apt-get install firefox-plasma[/code]

but it won’t download version 39. It keeps ttelling me 37.0.1 is the latest.

Here too it is 37.0.1only, whereas my Desktop’s Mint 17 KDE installed v-40 today on 13th Aug 2015.

Hi all,

have you switched to the latest repo since Netrunner 16?

According to the ppa Firefox 39 is the latest plasmafied version.
The Netrunner 15 one has been deprecated for a mozilla universal repo with unified plasma-support for both mozilla products:

sudo add-apt-repository ppa:plasmazilla/releases
sudo apt-get update
sudo apt-get install firefox-plasma thunderbird-plasma

If that doesnt work, there is likely an Launchpad internal error or mismatch somewhere…

Hi starbuck,

Thanks, it worked.
I removed ppa:moz-plasma/releases and added ppa:plasmazilla/releases
Reloaded and updated firefox 37.0.1 to 39.0.
But what about the newbie?
Netrunner 14.1 is my main OS. I like it very much and want to go on recommending to all the Linux beginners.
With regards.
[Somehow ,the replied post is not quoted in the reply. This is for the second time.]

Because I was stuck with version 37, I downloaded firefox 39 for linux from Mozilla’s website last month and have been using it instead of the one included in Netrunner. So far it remains up to date (40.0.2) .

What is the point to stay with the version that comes with Netrunner and won’t update because ppa names aren’t correct. And assuming we manually fix the ppa adress why would it be better ? Updates are always behind, it seems.

How do I do that?

You can do that in synaptic’s software sources dialog.
There you can deactivate software sources and add new ones.
However you can also use the terminal to do that like for example

sudo add-apt-repository --remove ppa:moz-plasma/releases
sudo add-apt-repository ppa:plasmazilla/releases

Thanks that worked:D I just wish it was the patched version of Firefox 39.0.03 or higher.
And how stable is the main edition of Firefox compared to the plasma version?

We now ship Firefox 40.0.3 with two important security updates and fixes to the gstreamer backend.
See the official news from Mozilla about the changes:

Good day!
What is the release cycle for Firefox-plasma package?
In Mozilla portal firefox-41.0.1 is available with many bug fixes, but in your repository only 40.0.3 is available.

At the moment there is no new build available with plasma patches.

Firefox 41 is now ready in the plasmazilla repo.