back to Netrunner | back to Blue Systems

Latest update blocks login


#1

I just updated my Rolling installation on one of my PC’s. It was a large update, around 1 Gig I think.
Everything seemed to go fine except that upon reboot I can’t log in. I am presented with the login screen but when I enter my password the login screen momentarily disappears and is replaced by a few lines from the bootup, then it reappears and I’m back to the beginning again.

I should also note that I had set the system clock to be on local time but after the reboot it displayed UTC time until my first login attempt, then the login screen refresh showed local time. Upon rebooting into Windows (since I couldn’t log in), I found that my hardware clock had been reset to UTC, so the update must have steamrolled my hardware clock setting.

Any suggestions for logging in?
Thanks


#2

I have the same problem too with the login.
A workaround for me was to do the login in a terminal and after that
startx
Once presented with a really simple desktop
startplasma-x11

Now Im back in my normal environment, but with nrr being deprecated, I installed manjaro.


#3

Netrunner Rolling is deprecated? I hadn’t heard about that.
Is the news posted somewhere?


#4

#5

Since I couldn’t log in, and the future seemed uncertain for the distro, I installed Ubuntu Studio instead. I’ll give that a try for a while and see how it works out for my needs. I may switch to Manjaro in the future and apply the Arch pro-audio group and see how that goes, or I might just go plain vanilla Manjaro. I’m going to take this opportunity to trash my way through a few distros and see what’s new out there since I’ve been on Netrunner for a few years now.
Thanks for all of the work and assistance.


#6

I’m sorry to see you go, and do hope to see you again soon. Whether here with one of our our debian editions, or over on the Manjaro forums where I will now be more active.

Just as an FYI, the login issue only effected systems that were installed with an ISO prior to our 2019.04 release. On these systems we had a default-settings-sessions-debug package that added a plasma-debug.desktop file for developers to use. For some reason sddm started to log into plasma using this file instead of the plasma.desktop file by default. The main issue with this after a recent update plasma started to crash when trying to login to debug mode (probably a bug). The solution was to just remove the default-settings-sessions-debug package from your system to log in normally.

I do apologize for the inconvenience this has caused you.


#7

What almost always helps is looking at Manjaro KDE forums if the problem is known and solved there:


#8

Sorry for the delayed reply, but I only became aware of this message earlier today. Not sure if I missed the email or what.
So I tried Ubuntu Studio. For about a day. After installing it I found that the mouse was lagging like crazy. A search in the forums indicated that it might be related to the kernel, so I booted into the alternate and the problem went away. Still, that got me thinking that I should really try Manjaro. After all, while using NetRunner I had seen that it had rt kernels so it was probably useful for audio work. So now I’m on Manjaro and liking it. One thing that’s odd on one of my two machines is that the ‘start button’ doesn’t appear; it’s usable but there’s just a blank in its spot. I tried changing themes and whatnot but it remains invisible. The other machine (that I’m typing on right now) shows it so it must be a glitch in the install, though I used the same USB stick for both.

As for NetRunner, I was somewhat confused and still am I guess. I wasn’t aware of the changes to Rolling, i.e. what sounded like it was becoming unsupported, until I made this post and saw a reply about it. I guess it was just Rolling that was ended then? I suppose I could have moved over to a Debian version but I’m here on Manjaro now and will run that for a while and if it goes well possibly quite a while. I enjoyed using NetRunner and prior to seeing your post today thought that it was folding up completely. I guess I was wrong about that, obviously.

Well, I’ll no doubt be on the Manjaro forums when I get stuck with something, so I’ll see you there.


#9

Thanks for the lengthier post CranKey.
We now have a direct collaboration with Manjaro, so for us it is the philosophy to help upstream whenever possible.
Netrunner Rolling had some unique customizations, but Manjaro KDE is not far from it.
The collaboration allows to help Manjaro detect issues more early, via a “Manjaro KDE vanilla dev edition”, so that effort seemed more useful to concentrate on this than yet another set of our own modifications downstream.

If someone is interested, just give it a try :slight_smile:


#10

If you haven’t changed anything for the panels or desktop yet, the fastest way to got the Icon back would be to open system settings, navigate to Global Themes, click on “use desktop settings from theme”, and lastly click apply.

Otherwise right click on the blank menu widget, click on “Configure {menu name}”, click on the icon, select “Choose Icon”, then in the search box type “Manjaro”, then just select one of the Manjaro icons and click apply.

I’m still here to support those running NRR, and also in the Manjaro forums to support Manjaro KDE edition as well. I also put together a tutorial on switching from a NRR install to Manjaro’s branding, etc., which I have pinned here: Netrunner to Manjaro tutorial.

Yes, Manjaro does offer alternative realtime kernels based on our long term supported kernels. We also offer many opensource, professional quality, audio and video applications and utilities within the Manjaro repositories.


#11

For the start button issue I used a variation of your second suggestion. I right clicked on where the button should be and choose 'Show Alternatives". I selected a different alternative and the button appeared, and then it remained there when I switched. The icon seems to be from the ‘Ditto’ selection, it looks like a pear with a bite taken out of it, but it stays there regardless of which variant I have selected. It doesn’t bother me, I’m just mentioning it for completeness sake.