Netrunner Home

LibreOffice Version: 6.1.5.2 is extremly slow


#1

Hi,

when I want to save a document with LibreOffice on our office file server it takes about a minute to do this. To open the documents takes not so long as to save but nevertheless it’s too long.
I tried it with a new, very small document … very, very slow. Then I opened a .txt-file with LibreOffice and saved it. About 1 Minute. The same .txt-file opened with an editor is saved in about a second.

What can I do to improve this?

Ciao!

Dieter


#2

Can you try start it from terminal to see if there is any error message that could explain this behavior


#3

In terminal

libreoffice /home/pfiff/Network/together/01\ Buero-Organisation/12\ Zeiterfassung/Zeiterfassung\ 2019/ZE-\ Dieter\ 2019.ods 

no further message, but i waited about 50 sec for opening, saving about 60 sec, no message as well.

???

I tried to open a document in my cloud

libreoffice /home/pfiff/Nextcloud/About.odt

that takes about 1 sec.

???

Ciao!

Dieter


#4

So the issue is that the smb Network one is loaded via the network directly. This is for some reason slow.
Have you tried it via the KIO smb:/ protocol instead? (entering smb://)
This will copy the file over to /tmp first before opening it up. See if it is any quicker.

Nextcloud loads a lot faster as it isn’t a remote file you are accessing but a local copy on your harddrive.


#5

ok, when i open the files for libreoffice in dolphin with smb://… then libreoffice is working pretty fast, but i always have to answer completly unnesessary questions. 1. The document has been changed. Do you want to save it? and after saving 2. Do you want to uploud the changed doccument.
Is there a chance to bypass this behavour?

Ciao!

Dieter


#6

That is not possible as far as I am aware.


#7

ok, …
next question: is it possible to improve the speed in the modul “Netzwerklaufwerke”. I established the connection with this modul.
In my former netrunner-os it has been working with this modul very fast.
Ciao!

Dieter


#8

Samba-Mounter how it is called is using mount.cifs to mount the samba shares.
In order to know why it is so slow I would try maybe mounting your drive manually from the commandline and see this german speaking tutorial for example: https://wiki.ubuntuusers.de/Samba_Client_cifs/#Temporaeres-Einbinden

Would be nice to see if it prints out any errors or warnings when executing and if you are able to reproduce the issue with the slow opening of files with this method aswell.


#9

Hi,

thanks for your reply. But sorry, i’m not able to connect manually. That’s too sophisticated for me. Too much unknown paramaters for me and I don’t have the necessary background knowledge for this problem.
Example in fstab:

//192.168.178.1/Backup /media/Backup cifs password=  0 0

is not working. mount -a

mount: /etc/fstab: Einlesefehler in Zeile 12 -- ignoriert

Maybe somebody can take me by my hands and helps me through this problem.

Ciao!

Dieter


#10

Hi Dieter,

that is really weird, as normally via sambamounter mounted shares are much faster than kio.
It would be really interesting to find out why it is reverse on your side, so if you use samba-mounter, how does your fstab look like?


#11

Have you entered a password there and not left empty?
Have you tried manually mounting first with sudo mount … in a terminal?


#12

Hi and thank you for your answer.

There is no password set for the users on the samba-Server. And yes i always tried to mount with sudo mount -a manually.

Ciao!

Dieter


#13

Hi and thank your for your answer.

My fstab looks like this (in the moment)

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=a0abbaab-5411-4655-b82d-973ad9914a08 /home          ext4    defaults,noatime 0 2
UUID=a6212a87-6a64-4df4-836f-c3170b5c4459 /              ext4    defaults,noatime 0 1
UUID=4b8e87b6-9e78-41d8-aa6e-30f2d9d308c1 swap           swap    defaults,noatime 0 2

# //192.168.178.100/together    /home/pfiff/Server cifs username= password=  0 0

The last line has been for testing.

Ciao!

Dieter


#14

The username= and password= are the issue. Please add a comma in between them
so it looks like

//192.168.178.100/together /home/pfiff/Server cifs username=,password= 0 0

Then please try again.


#15

Ok, tried it again. It’s again very, very slow … compared to “smb://dieter@192.168.1.100/together/” in dolphin it takes almost a minute longer to start or save a file. But, meanwhile i tested the speed for different kind of files. It’s for all kind of files the same issue. So the title of this thread is wrong. (sambamounter is extremly slow)

Ciao!

Dieter