Linux mint repo and Minstick

I can’t install Mintstick 1.2.1 from the Linux Mint repo.
This is what I did on Ubuntu and that works great :

$ sudo add-apt-repository "deb qiana main" $ sudo apt-get update $ gpg --keyserver --recv-keys 3EE67F3D0FF405B2 $ gpg --export 3EE67F3D0FF405B2 > 3EE67F3D0FF405B2.gpg $ sudo apt-key add ./3EE67F3D0FF405B2.gpg $ rm ./3EE67F3D0FF405B2.gpg $ sudo apt-get update && sudo apt-get install linuxmint-keyring $ sudo apt-get update && sudo apt-get install mintstick

But in Netrunner even if I add the Linux Mint repo it’s the old version (1.0.6) from Netrunner repo that install.
Any idea ?

Thank you.

If it worked on Ubuntu you should have no problem in Netrunner Standard (Kubutnu). For those running Netrunner Rolling it’s in the AUR: mintstick-git

Yes I agree but that doesn’t work. It’s like the linux mint repo is not taken into account.

Since These two distributions share the the same Ubuntu Base, why can’t that package be downloaded and installed locally without adding the repository?

[color=#000080]Just try and I installed without problems.[/color]

Ghermain did you add the repository or download and install the package manually?
I’ve haven’t really used Linux Mint before and I was curious, so I installed mintstick from The AUR and I actually like it better than SUSE Imagewriter, I really do, that is one (actually two) really nice utility.

yaourt -S mintstick-git

I wonder if besides mintstick and mint backup what other nice Linux Mint ustilies are available in the AUR?
I must now check, LOL :wink:

I already tried to download and install the package. It works but it’s always better to use the repo for updates and a better package management.
What I do not understand is that with Ubuntu 14.04 it works.

I agree with you, it’s a really useful soft to format a USB stick and write an iso.
OK I can force the installtion of Mintstick from Linux Mint repo with synaptic.
But I still don’t know what’s wrong.
I found the problem, it’s the repo priority in /etc/apt/preferences.d
How can I fix that properly ?

[color=#000080]I installed by copying what @paviluf left in the comment, or adding the repository.[/color]

You certainly have installed the version 1.0.6 who is in the netrunner repo which takes precedence of linux mint repo.

I think the simplest solution is to install it manually but if someone has a good idea I’m listning.

[color=#000080]No version is that I do not see how to find out, leave a screenshot.[/color]

dpkg -l | grep mintstick

[color=#000080]Gracias, no sabía como hacerlo, este es el resultado:[/color]

It’s the latest version from mint repo. I don’t know why it’s working for you because for me the repo of netrunner takes precedence.

[color=#000080]Disable (uncheck) the repository Netrunner while installing …

Sorry for posting in the Frontier subforum but I wanted to avoid opening another thread…I don’t know have you tried to format usb device with mintstick tool but I always get an error. I also tried from konsole but without any luck.

Yea it doesn’t seem to actually work on my system either, what a shame it looked so nice too.

No problem on Netrunner 14

[quote=“paviluf, post:1, topic:2698”]
I can’t install Mintstick 1.2.1 from the Linux Mint repo.[/quote]
To answer to myself it’s a bad idea to add the Linux Mint repo because :

  • Netrunner repo take precedence on Linux Mint repo
  • If you make Linux Mint repo prioritary some Netrunner system packages will be replaced

So the best way to install Mintstick is to install it manually. Maybe the devs can update it to latest version in Netrunner repo to simplify the installation :wink:

Yea, under Netrunner Rolling there is probably just a permissions issue or something else that easily fixed, i just don’t have time to look into it right now.

Is advertisement allowed on this forum, coz this guy is spamming all over the place.

This happens from time to time, It’s best to just ignore this until leszek has a chance to see these and clear them out.