Login hangs after new installation


After I have installed Netrunner 17 from DVD (checked on errors) and want to login, the user login hangs. Nothing happens and nothing is possible anymore but reboot. Tried to install with LVM and without. I also checked the encrypted home space. Haven’t tried without beause I really would like that.

Any ideas?


Hang means it freezes ? Or it just doesn’t load the desktop ?
Can you still switch to a tty (for example Ctrl+Alt+F1) ?
Is there anything useful in the ~/.xsession-errors file (can you take a look from a live system. The file is hidden by default in the users directory of the installed system)

Freezes. Nothing happens. the mouse is gone. Sometimes its replaced by an X (from X-server?) when I choose Failsafe I get back in the same screen over and over (it flickers once) and that’s it. Im not home this weekend, will give you more details monday. (btw: the live-DVD works lile a charm)

I am having the same issue also.

When I choose “Plasma” from the drop-down menu on the left and enter my password, the cursor changes to an “X” and it essentially “freezes”

If I try logging in in “failsafe” mode, the screen turns black for a second and then it takes me back to the login screen.

I am able to get to a tty screen using the method you described, and I can login there, but I don’t really know what to do from there.
I was able to install lynx and view text versions of websites though.

It’s possible to get into tty and login. I cannot start KDE as it give the display-error. When I try to set display=:0.0 everything freezes and the only thing I can to is reboot. Typing startx also freezes everything.

For your second question: I tried to get to the ~/.xsession-errors but I cannot get into my newly made home dir. When I clicked the ‘encrypt home dir’ option, I wasn’t presented with the mount passphrase and I am not able to restore. In my trials to get it, somewhere it gave the message that the encryption wasn’t set up properly.

I will now try to install without encryption and make another user with encryption later. See what happens.

I think that might be the issue then.
SDDM doesn’t need your home directory to load, the Plasma desktop does.

Yes I also think so.
Please try if it works unencrypted.

Ok, I’m now posting this from my laptop. But it wasn’t working properly. The graphical login screen failed and I had to go to tty. From there startkde and startx weren’t running untill I gave the command export DISPLAY=:0.0 ; startx and then Netrunner showed itself in full glory!

The .xsession-errors is quite big[attachment=814]. Don’t know if thats normal. For your reference I attached it.

I did some updates via Muon and afterwards KDE froze. I did a hard reboot and the splash screen hanged again, showing me the X as a mouse pointer. I went into tty and had to export the DISPLAY again before I could startx.

So I guess the problems are related to X and not to encryption.

Any ideas?

I don’t see anything useful in the xsession-errors file.
Can you check Xorg.0.log in /var/log if there is any error message.
Also it might be helpful to see the dmesg output after the sddm login fails (when seeing the bare Xorg switching to tty and see the last messages of dmesg)

Strangely, when I add a new user with encryption, I can login normally (although Between the splash and the kde there’s a black screen for a long time).

Ive added the logfiles.[attachment=815]

Did a fresh re-install with home dir encrypted. During startup the splash screen hangs, tty shows that something is wrong with ecryptfs setup. I get the message ERROR: Encrytped private directory. When trying to login I get all kinds of errors saying that the writing rights are not set.

So ecryptfs is not decrypting as it seems. Maybe sddm needs support for it. We’ll investigate.
For the time being could you try installing lightdm as alternative login manager and try with it.

Im happy to test further, but I need the laptop again…

I got the same problem after installing all i get the same thing as use Marko is getting but I am on remote so nothing more i can do rather dropping it and changing the for a person who comes from windows so i have to make him change to another distro :frowning:

Have you tried lightdm instead of sddm ? As it obviously has problems with ecryptfs I would try out another login manager instead.


new to netrunner. Not a complete newbie…just a linux explorer since about 1998 off and on.
I installed 17 horizon 64 bit off dvd image.
nvidia card - amd quad proc - 8gig ram -etc.
dual boot with win and mint.

anyway— was having exact issues as marko.
would get to login and after inputing pass it would go to an “X” mouse pointer and hang there forever never loading desktop.
I too installed using encrypted home directory.
tried going in manually also to start X or KDE. NO LUCK
Then I took advice posted here by lezek and did a reinstall but did not encrypt home directory. Everything else exactly the same.

I noticed the install went much faster and it logged right in after install and loaded desktop with ZERO ISSUES!
So, it would appear the encryption option causes this issue.

Only other buggy issue I notice so far is after install when you choose restart, it hangs forever with no video input or prompt to remove dvd or anything.
I manually opened dvd and removed and manually restarted with power reset button.
That’s kinda dodgy, but it did the trick and caused no problems.

Thank you for what seems to be a great flavor of linux.
You can tell it’s had loads of effort in the polish.
Hope this post helps any others with the desktop login bug.
CHEERS! :slight_smile:

so… any ideas on setting home encrypted and still being able to logon? Would prefer to have the encrytion.

Did you try out a different login manager like lightdm already?

No I did not. Would rather have it working the right way. I already applied a band-aid of not having an encrypted home directory to fix login.
A band-aid I prefer at this point.
Need to get the bug fixed that causes it not to decrypt so plasma desktop loads.
Fixing that is past my talents.
Not a programmer just a lowly user :stuck_out_tongue: .

Thanks :wink: