Login Problems - don't know why

ok, so my Netrunner was working well as usual with no issues at all.
After switching my PC on yesterday, the system loads up, shows the login screen (as usual) and then I enter the password — then nothing, the screen literally just freezes. I then used Ctrl+Alt+F2 to login, it worked, just, now I only have command line - which is great, but I want to look at pictures.

I’m not sure what the actual problem is, but I suspect the login screen itself as logging into any other window managers give the same result. :huh:

Edit- OH; I’m sure it has nothing to do with anything at all, but - I triple boot my PC with Netrunner, Linux Mint and Windows 7. Iv’e been doing this for a long time, so I doubt this is the issue, but it might be helpful to solve the problem with.

What GPU do you have, and which drivers are you running?
Are you sharing a home, or any other partition, with Linux Mint?
Can you please post the contents of your xorg log file?

Hi, I am using the proprietary Nvidia Drivers, not Sharing a home partition.

Not according to Xorg your not:

quote AIGLX enabled
[ 388.824] (II) LoadModule: “nouveau”
[ 388.824] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[ 388.826] (II) Module nouveau: vendor=“X.Org Foundation”
[ 388.826] compiled for 1.17.4, module version = 1.0.12
[ 388.826] Module class: X.Org Video Driver
[ 388.826] ABI class: X.Org Video Driver, version 19.0
[ 388.826] (II) NOUVEAU driver
[ 388.826] (II) NOUVEAU driver for NVIDIA chipset families :
[ 388.826] RIVA TNT (NV04)
[ 388.826] RIVA TNT2 (NV05)
[ 388.826] GeForce 256 (NV10)
[ 388.826] GeForce 2 (NV11, NV15)
[ 388.826] GeForce 4MX (NV17, NV18)
[ 388.826] GeForce 3 (NV20)
[ 388.826] GeForce 4Ti (NV25, NV28)
[ 388.826] GeForce FX (NV3x)
[ 388.826] GeForce 6 (NV4x)
[ 388.826] GeForce 7 (G7x)
[ 388.826] GeForce 8 (G8x)
[ 388.826] GeForce GTX 200 (NVA0)
[ 388.826] GeForce GTX 400 (NVC0)
[ 388.826] (++) using VT number 2[/quote]

What is your exact Nvidia chip?

inxi -G

That’s odd… I use a GTX 750.

How did you install the Nvidia driver?
Under Netrunner Rolling (Manjaro) mhwd needs to be used.

sudo mhwd -a pci nonfree 0300

Yeah, I still remember installing it a long time ago with the mhwd GUI tool. I’ll try the command anyway, fingers crossed.

Ok, nothing… switching to the nouveau drivers doesn’t do anything except a blinking underscore.
why doesn’t it detect a screen though? - I am going to try an HDMI-input screen, maybe it’ll do something diffrent.

the auto install on mhwd didn’t start because it was already installed - but I removed it and reinstalled it and switched back and forth between the nvidia and the nouveau drivers, every time the x.org log file says the same thing. - no screen

That IS strange, installing the nvidia driver with mhwd should automatically blacklist the nouveau drivers.
We might need to take another approach.
First, you don’t happen to have a hybrid graphics system do you?

If not then:

sudo mhwd -f -r pci video-nouveau 
sudo mhwd -f -i pci video-nvidia

You can check your configuration with:

sudo mhwd-gpu --check
sudo mhwd-gpu --status

And if needed fix issues with:

mhwd-gpu --setgl
mhwd-gpu --setxorg

If you plan on using nvidia-settings to control you display:

sudo nvidia-settings

Make sure you hit the ‘Save to X Configuration File’ button and save to /etc/X11/mhwd.d/nvidia.conf.

After that you’ll need to run the following:

sudo mhwd-gpu --setgl nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

I’ve tried doing what you suggested, the only problem is that I don’t know enough about the Nvidia settings to know what’s really going on with them… I have however, gone to the deep depths of self pity and installed the vesa Display package… Still to no avail.
I think the problem might be X itself, though I don’t know exactly how all why.
I don’t understand how the login screen pops up so majestically… But after I enter the password nothing happens.

Ok also tried various screen setups after reinstalling the nvidia drivers again… Still nothing. Nothing more than the login screen and nothing after a correct password entry.

OK, the log in screen is running on X so that isn’t the issue. More than likely the issue is with Kwin and/or the compositor.
try deleting ~/.config/kwinrc from a terminal prior to logging in via sddm (GUI).

sudo rm .config/kwinrc

Bump, nothing changed.

Ok, so I now also removed the last programs I installed - then reinstalled the video-nvidia package, still not. I also tried some solutions offered by other forums but because manjaro based distros work a little diffrent they don’t offer a solution for this case.